I just upgraded to macOS Ventura and now my external monitor (BenQ PD2700U, 27" 4K monitor) is all screwed up. The resolution is very tiny. The scaling option is no longer in Settings > Display. You can only switch between "1920x1080 (Default)" which looks enormous, unclear, and awful, or this tiny "3840x2160 (low resolution)" that looks clear but is nearly illegible it's so tiny. I've downloaded all kinds of apps trying to fix this to no avail. I never had this problem with the exact setup in Mojave. Any suggestions?

  • 1
    Seems you're not alone - apple.stackexchange.com/questions/449536/… This is why it's always wise to wait for at least the 'point one' release. Let other people bug test.
    – Tetsujin
    Oct 25, 2022 at 15:02
  • And always ensure you have a backup so you can easily revert the system.
    – X_841
    Oct 25, 2022 at 15:20

2 Answers 2


As mentioned in the comments, it seems like a Ventura bug.

When I was in the Beta, I used this tool to select resolutions that the OS didn't provide https://github.com/waydabber/BetterDisplay

  • 2
    BetterDisplay has seemed to enable the solution, non-native. Thanks so much! Oct 25, 2022 at 17:11
  • I have been fighting Ventura to recognize 2560 x 1440 as the proper default resolution for a 32" LG UltraGear for well over a month. BetterDisplay has been the only solution that "just worked." Sorry to say I've been incredibly underwhelmed with Ventura and have regretted upgrading to it from day one.
    – Joe
    Feb 24 at 3:49

Unplug the display from the power. Wait a minute. Plug it in again. That solved it for me. Restarting the display with the power button / sleep button did not work for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .