MacOS asked me for update to EFI 2.7, I said ok. After rebooting I came up to the login screen. When I use my password for a moment I could see grey screen with mac's progress circle but then It returned to the login screen. In case if I use a random password, there are no this grey screen. I used disk utility to verify that the disk is ok. It had some minor problems so I used "repair". And now it says that the disk is ok. I tried to go to the single user mode and reinstall this update

sudo /usr/sbin/bless -mount / -firmware "/System/Library/CoreServices/Firmware Updates/MacBookProEFIUpdate-2.7/MBP81_0047_27B_LOCKED.scap" --recovery --verbose

It wrotes:

Substituting ESP disk0s1
Can't create mountpoint /Volumes/bless.ZZ2b
Executing "sbin/mount"
mount: realpath /Volumes/bless.ZZ2b: No such file or directory
Returned 256

Any ideas?

2 Answers 2


There are really two problems here:

  1. Can you make a new admin account in single user mode and use the Mac?
  2. Do you need to recover from the failed EFI update or will it work once you address #1.

It's not possible to do anything other than guess which is the real cause. I will try to give steps for either in case you want to work this out and come back and ask a more specific question once you've narrowed down which is the failure here.

In the prior - you can either boot from an external OS and try to fix the account and/or boot situation.

In the latter - booting from an external OS is ideal to attempt the EFI update again without further harming the normal user and OS. It also allows a backup if needed and you did not make one immediately prior to running the EFI updates.

It's rare for an EFI to get stuck when there isn't another hardware or drive corruption issue - but this is one of the reasons why many are in the habit of

  • always backing up before any update that requires a reboot
  • rebooting and running a clean backup with nothing running, then rebooting and running the EFI update as the first task of the OS.

Recovering from an EFI update failure often involves a trip to the repair center since EFI is the initial bootstrap mechanism of the hardware to run in the first place.


Try too enable verbose and/or single user mode in order to find the cause.

And, as always you can go to Apple for help, but probably this is not what you were looking for.

  • yes, I tried. Updated post. Finally, I gave mac to apple's guys. Mar 22, 2012 at 15:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .