I am using a mid-2010 Mac Pro with the latest Monterey 12.6 using OpenCore. Everything works perfectly except for some Firewire audio mixer I am trying to use (Mackie Onyx 1640i).

I am connecting it to my Mac Pro using a FW400 → FW800 Belkin cable. At first, it worked well, as this mixer driver is embedded in CoreAudio. After rebooting once, this "good luck" ended, and every time I am switching to use it, I get a kernel panic, and my Mac reboots. It happens both when I try to switch my DAW (Logic Pro) to use it, but also when selecting it as the sound source in macOS.

I tried installing Big Sur on another disk and the same issue occurred.

Here is the kernel panic log:

panic(cpu 2 caller 0xffffff800d9d0833): Kernel trap at 0xffffff7fa504cb90, type 14=page fault, registers: CR0: 0x0000000080010033, CR2: 0x0000000000000000, CR3: 0x0000000211e7c082, CR4: 0x00000000000226e0 RAX: 0x0000000000000000, RBX: 0xffffff970b188800, RCX: 0x0000000000000000, RDX: 0x0000000000000000 RSP: 0xfffffffff2833ca0, RBP: 0xfffffffff2833cd0, RSI: 0x000000000000073c, RDI: 0xffffff970b188800 R8: 0xffffffa56e96ec80, R9: 0x0000000000000030, R10: 0xffffff90a39a5738, R11: 0x0000000000000000 R12: 0xfffffffff2833ca4, R13: 0x0000000000000000, R14: 0x000000000000073c, R15: 0xfffffffff2833ca0 RFL: 0x0000000000010246, RIP: 0xffffff7fa504cb90, CS: 0x0000000000000008, SS: 0x0000000000000010 Fault CR2: 0x0000000000000000, Error code: 0x0000000000000000, Fault CPU: 0x2, PL: 0, VF: 0

Panicked task 0xffffffa56f21f670: 22 threads: pid 328: coreaudiod Backtrace (CPU 2), panicked thread: 0xffffffa5747eb540, Frame : Return Address 0xfffffffff2833650 : 0xffffff800d87fdad mach_kernel : _handle_debugger_trap + 0x41d 0xfffffffff28336a0 : 0xffffff800d9e10d6 mach_kernel : _kdp_i386_trap + 0x116 0xfffffffff28336e0 : 0xffffff800d9d0443 mach_kernel : _kernel_trap + 0x4d3 0xfffffffff2833730 : 0xffffff800d81fa70 mach_kernel : _return_from_trap + 0xe0 0xfffffffff2833750 : 0xffffff800d88017d mach_kernel : _DebuggerTrapWithState + 0xad 0xfffffffff2833870 : 0xffffff800d87f936 mach_kernel : _panic_trap_to_debugger + 0x2b6 0xfffffffff28338d0 : 0xffffff800e115093 mach_kernel : _panic + 0x84 0xfffffffff28339c0 : 0xffffff800d9d0833 mach_kernel : _sync_iss_to_iks + 0x2c3 0xfffffffff2833b40 : 0xffffff800d9d0516 mach_kernel : _kernel_trap + 0x5a6 0xfffffffff2833b90 : 0xffffff800d81fa70 mach_kernel : _return_from_trap + 0xe0 0xfffffffff2833bb0 : 0xffffff7fa504cb90 com.apple.driver.AppleFWAudio : __ZN14AM824NuDCLRead22PreProcessInputSamplesEPKvjjPK20_IOAudioStreamFormat + 0xb4 0xfffffffff2833cd0 : 0xffffff7fa502a3f1 com.apple.driver.AppleFWAudio : __ZN18AppleFWAudioDevice22PreProcessInputSamplesEPKvjjPK20_IOAudioStreamFormat + 0xe1 0xfffffffff2833d20 : 0xffffff7fa501df9d com.apple.driver.AppleFWAudio : __ZN22AppleFWAudioIsocEngine19convertInputSamplesEPKvPvjjPK20_IOAudioStreamFormatP13IOAudioStream + 0x119 0xfffffffff2833d80 : 0xffffff7fa68c34ed com.apple.iokit.IOAudioFamily : __ZN13IOAudioStream16readInputSamplesEP19IOAudioClientBufferj + 0x113 0xfffffffff2833de0 : 0xffffff7fa68be374 com.apple.iokit.IOAudioFamily : __ZN23IOAudioEngineUserClient18performClientInputEjP22IOAudioClientBufferSet + 0x14e 0xfffffffff2833e50 : 0xffffff7fa68bdd7a com.apple.iokit.IOAudioFamily : __ZN23IOAudioEngineUserClient15performClientIOEjjbjjj + 0x14e 0xfffffffff2833ea0 : 0xffffff800e08564f mach_kernel : _iokit_user_client_trap + 0x1af 0xfffffffff2833ef0 : 0xffffff800d9b30aa mach_kernel : _mach_call_munger64 + 0x1ea 0xfffffffff2833fa0 : 0xffffff800d820256 mach_kernel : _hndl_mach_scall64 + 0x16 Kernel Extensions in backtrace: com.apple.iokit.IOAudioFamily(340.2)[3E9A6341-0E01-36B0-8E53-7C13421313CF]@0xffffff7fa68b0000->0xffffff7fa68cdfff dependency: com.apple.vecLib.kext(1.2.0)[5C258176-730D-39DE-8F27-00EA4F281CAF]@0xffffff7fa7493000->0xffffff7fa7551fff com.apple.driver.AppleFWAudio(270.19.2)[C914C09D-D35C-3F99-8254-9FE1C6C11D00]@0xffffff7fa501c000->0xffffff7fa505afff dependency: com.apple.iokit.IOAudioFamily(340.2)[3E9A6341-0E01-36B0-8E53-7C13421313CF]@0xffffff7fa68b0000->0xffffff7fa68cdfff dependency: com.apple.iokit.IOFireWireAVC(4.2.8)[6C0E188A-2C3C-331F-9912-A8A67AB5CF64]@0xffffff7fa68ea000->0xffffff7fa68f5fff dependency: com.apple.iokit.IOFireWireFamily(4.8.3)[6B22B0E2-8560-3F51-AEEA-A0DB69F42677]@0xffffff7fa68fd000->0xffffff7fa6930fff

Process name corresponding to current thread (0xffffffa5747eb540): coreaudiod Boot args: keepsyms=1 debug=0x100 -lilubetaall ipc_control_port_options=0 -revasset

Mac OS version: 21G115

Kernel version: Darwin Kernel Version 21.6.0: Mon Aug 22 20:17:10 PDT 2022; root:xnu-8020.140.49~2/RELEASE_X86_64 Kernel UUID: 06A10466-36D7-3A0B-9EE7-A9053A8991A3 KernelCache slide: 0x000000000d600000 KernelCache base: 0xffffff800d800000 Kernel slide: 0x000000000d610000 Kernel text base: 0xffffff800d810000 __HIB text base: 0xffffff800d700000 System model name: MacPro5,1 (Mac-F221BEC8) System shutdown begun: NO Panic diags file available: YES (0x0) Hibernation exit count: 0

System uptime in nanoseconds: 262313252676 Last Sleep: absolute base_tsc base_nano Uptime : 0x0000003d1316a0d4 Sleep : 0x0000000000000000 0x0000000000000000 0x0000000000000000 Wake : 0x0000000000000000 0x0000001340bd49bc 0x0000000000000000 Compressor Info: 0% of compressed pages limit (OK) and 0% of segments limit (OK) with 0 swapfiles and OK swap space Zone info: Zone map: 0xffffff90a2995000 - 0xffffffb0a2995000 . PGZ : 0xffffff90a2995000 - 0xffffff90a3996000 . VM : 0xffffff90a3996000 - 0xffffff95703fc000 . RO : 0xffffff95703fc000 - 0xffffff9709cc8000 . GEN0 : 0xffffff9709cc8000 - 0xffffff9bd672e000 . GEN1 : 0xffffff9bd672e000 - 0xffffffa0a3194000 . GEN2 : 0xffffffa0a3194000 - 0xffffffa56fbfa000 . GEN3 : 0xffffffa56fbfa000 - 0xffffffaa3c661000 . DATA : 0xffffffaa3c661000 - 0xffffffb0a2995000 Metadata: 0xffffff901a8b3000 - 0xffffff903a8b3000 Bitmaps : 0xffffff903a8b3000 - 0xffffff903d8b3000
  • 1
    I'm actually surprised it worked at all. There is no Mac capable of running Big Sur or Monterey that has Firewire too, so I'm surprised the drivers were included. btw, the formatting you used on the panic report makes it really hard to read. If you just copy/paste as-is, then select & hit ctrl/K it will format with the original line breaks.
    – Tetsujin
    Oct 17, 2022 at 17:39
  • 1
    There are some musings on gearspace.com/board/music-computers/…
    – Tetsujin
    Oct 17, 2022 at 17:43
  • Thank you. First i changed the formatting. Second, the gearspace forum i already found and actually posted a question there but no comments. There are a lot of guys there using exactly my mixer with success even on Monterey. But i suspect they are using thunderbolt with a firewire->thunderbolt adapter which explains why it works. But are you saying that apple officially dropped support for fw starting big sur ?
    – OrPaz
    Oct 17, 2022 at 21:22
  • 1
    Wow, that comes out in really long lines - [it's not formatted properly, but it's easier to read as it is, so let's leave it.] It does appear to have FireWire drivers… & that's what's crashing. I've also only seen people using TB adapters to get them working. The OS itself is not expecting to see physical FW ports at all. Not sure what to suggest next - all my old Pros are still on Mojave, where they will stay, to retain the 32-bit support & my ancient Line6 hardware.
    – Tetsujin
    Oct 18, 2022 at 9:14
  • 1
    You should be able to get Mojave on there without a hack if you have a Metal2 GPU, not the original GT120 or HD5770. I have HD 7950s in the Pros here.
    – Tetsujin
    Oct 19, 2022 at 16:02

1 Answer 1


Ok mystery solved thanks to Tetsujin. It is all a matter of later Mac Os versions dropping support for 32bit drivers. I have installed both High Sierra and Mojave and the Mackie worked out of box without any issues. Of course this is all true using the builtin FW800 port on my MacPro, But if someone is using a newer mac with thunderbolt, even latest Mac Os versions are supposed to work using FW->Thunderbolt adapters.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .