1

Taking up for example the answer of Microphone not working on third party apps only (iPhone 6):

Under Settings > Privacy > Microphone you'll be able to allow/deny each app that require the microphone to use it.

I do not see any apps in the list. I only see one item called "App Clips", and in that item, nothing is listed. How can I get back all of the apps that need the microphone?

UPDATE 221016:

I see the allowed microphone for two messengers now, WhatsApp and Threema, after having agreed to share the microphone. They were not allowed anymore after resetting the iPhone settings to the default. But on the other hand, I did that reset only to get the microphone back, therefore, this cannot be the problem, the problem was there before. I could not find a way to allow the microphone for voice memos or calls, but that is likely just not needed.


The microphone is missing everywhere:

  • filming with front or back camera,
  • voice memos: you cannot even start the record,
  • speech-to-text in Whatsapp, Telegram, Signal, Threema, Notes and just everywhere else,
  • Siri,
  • phone calls with or without headset.

The Apple headset itself does not work either: plugging it in and out does not lead to any change in the played media, it will just use the loudspeaker at any time.

This is just a list of examples that I tried, it is clear that it does not work anywhere else.

The NFC scan that I need for a card reader and NFC payments does not work either. The iPhone seems to have a hardware problem: iPhone 7 NFC Reader not working.

I have an iPhone 7 with iOS 15.7.

8
  • 1. Do you have a management profile installed? 2. Have you tried restoring the device?
    – JBallin
    Oct 2, 2022 at 22:14
  • @JBallin 1. I vaguely remember having installed some profile when I tried to get a lower minimum volume. The minimum volume is still too loud for my ears in the morning. But I forgot how and what I did there. I somehow installed the profile or something the like from the shop, and I could not deal with it. 2. I have reset the settings, but not restored. Before I restore, I need to backup and clean my mobile phone, and so many apps would have to be reinstalled. I rather try to fix this before I take that step. I am sure that the mobile phone will work after that. Oct 3, 2022 at 18:12
  • Do you see any profiles configured under "VPN & Device Management"?
    – JBallin
    Oct 4, 2022 at 0:26
  • Yes, there is a profile in the "VPN & Device Management", but that was there since long. I also did not use it during the time when I ran into the loss of the microphone. I found the app which I used not long ago and which might have led to something. It is called "Shortcuts App", which I took from Can I set the volume on my iPhone lower than the slider goes?. But it turns out that it is alright, I checked the app again and found it working and not blocking anything. Oct 4, 2022 at 17:05
  • You say the profile has been there a long time, but that you didn't "use it" - this doesn't make sense. You don't "use" a profile, it's in the background on your phone. It's possible that the management settings from the profile changed, causing issues with your microphone. Can you try removing the profile temporarily to see if that fixes the problem?
    – JBallin
    Oct 4, 2022 at 19:31

1 Answer 1

0

Workaround found at least.

New Findings

With new in-ear Bluetooth earphones, the calls work. By this, I could avoid setting up a new mobile phone. I could not get the NFC scan to work, but that is less urgent.

Outdated (my older Bluetooth headset seems to have had problems)

When I connect with a Bluetooth headset, I can sometimes speak on a voice memo, or I can use the microphone in a messenger call, but only seldomly. I have to call people roughly 10 times over some range of time until one call might work. And if it works, and if you start right away with another test in the same or another app, it does not work again. I found out that the call often does not even get out in Whatsapp or normal call, saying "unable to initiate call, please try again". And you normally do not even hear the ring tone when calling someone, and then, the microphone will not work either or comes in only after 30s, and you cannot say why and did not do anything on both sides for this. You cannot plan it. I could not take any call up to now, it worked only in times when I called out. And all of this with the Bluetooth headset only.

After switching Bluetooth off again, I still cannot use my headset or speak on the microphone without headset, therefore, it cannot come just from a broken headset. I guess that the driver for the microphone is set off and that a full new install of the phone would solve this, but I do not want to install everything again.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .