So, my house has Wifi that works pretty consistently with all of our computers, both macs and PC's. However, we just set up our iMac (which runs Snow Leopard) for the first time in a few months, and data just trickles in. It usually connects to the router, but if a page loads at all it will take at least a minute (which is obviously entirely useless). I've tried playing around with AirPort settings a little bit, but nothing has worked. I've also done a good deal of internet searching, but nothing particularly helpful has arisen. So, does anyone have any possible suggestions?

I should also mention that I brought it to the Genius Bar to have this dealt with. When I was there, however, the store internet worked fine. This was after the employee showed me how to clear the PRAM, so we figured that this was the issue and I left on my merry way. However, the problem was the same back at home, no matter how many times I reset the PRAM.


It's not unknown for there to be incompatibilities between two things that are supposedly using the same WiFi standards especially since so many manufacturers departed from or anticipated the standards bodies in producing MIMO, draft-N (or even draft-G devices if you're dealing with something completely ancient). Is there an update available for your device?

What you didn't say was what kind of access point you have in the house and what kind of wireless radios are in the PCs that work. You mentioned Airport but you might have meant the WiFi settings on the menu bar, or if you did mean it is an Apple Airport then it might be an original graphite UFO, a white UFO, an Express or an Extreme. I switched to a current model Airport Extreme (square) in the past year and found speeds and signal strength far better than my previous white UFO Airport Extreme.

Another thing to look at is what channel the AP is on. Are there any other access points visible from your house? You might be suffering from collision with a nearby radio and switching the channel in use in your house could help. This old blog fro New Zealand has a good illustration of how various channels overlap, so switching might be worth a try, even if the diagram doesn't seem to suggest you have a conflict.

Finally - can you just try moving the AP or the machine to see if things improve? It might look like there aren't any wireless obstacles between the AP and your machine, but you might find a thin wall houses a whole lot of copper pipes or foil insulation, and can be a fairly effective wireless shield.

| improve this answer | |

Sounds like your internet connection is having some issues with traffic to/from sites.

Can you open 'Terminal' and type this:

traceroute google.com

then repeat with


and put the two results here?

| improve this answer | |
  • This should be a comment; answers should solve the OP's problem. – Timothy Mueller-Harder Mar 21 '12 at 0:02
  • It's an attempt to answer the question with some troubleshooting - let's see if it helps and things can edit into shape. People can vote to delete / close and down vote on the usefulness and then change as things edit better, but I don't want to delete this just yet. – bmike Mar 21 '12 at 0:11
  • I can't add comments until I get to 50 reputation. – Sal Conigliaro Mar 21 '12 at 3:45
  • The result was: 64 hops max, 52 byte packets Then it said "send to: No route to host" follow by three "send to: Host is down"s, and then repeated that a bunch of times. Its still repeating; I think I'll cut it off here. – Mike Mar 22 '12 at 12:27
  • Sounds like you have no WiFi connection. If you hold down the 'Option' key and click on the Wifi icon in the Menu Bar, what does it say for RSSI, Transmit Rate and MCS Index? – Sal Conigliaro Mar 23 '12 at 1:53

A few things to try:

  1. Go to Mac HD > Library > Preferences and delete (or archive) the folder called System Configuration. Reboot. You will have to choose and enter your Network password again. If that doesn't work.
  2. Create a test user account on your Mac if it does it here too after step one then it's a system wide issue (or your router)...
  3. Factory reset the router, I had the same problem recently, all other Macs were fine, restarting the router didn't help. Factory resetting the router fixed the issue.
| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .