I've installed tmux using brew ( arch -x86_64 brew install tmux ) on M1 Mac and since then my terminal is super slow. on lunch, after running commands and it's just incredibly slow.

I tried deleting the package using

brew uninstall pkg

it didn't work. I tried using the following commands as well.

brew remove pkg

brew rmtree tmux

I get "Error: tmux is not currently installed" since I've already uninstalled it..

and when using

sudo find / -name "*tmux*"

I still get many files including tmux.

GIF showing the situation ( delay in responding )

enter image description here

when entering the set -x command enter image description here

any ideas/help on how to solve this?


1 Answer 1


Ok I have fixed it.

although I didn't know exactly what was the problem but it was something related to oh-my-zsh and to be more specific it was with the current oh-my-zsh theme powerlevel9k after installing tmux.

here is the steps I toke: I tried to change my shell to bin/bash it worked great. Tried a couple more shells and all worked great except zsh. then I tried to change the .oh-my-zsh directory name just for testing purposes and opened zsh, it worked great but of course without oh-my-zsh.

so I went to .zshrc and commented this line.


obviously installing tmux messed things up so I'll need to reinstall the theme or oh-my-zsh all over again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .