I'm using Monterey 12.3.1 and tried to update it to 12.5.1. But at the first instance of trying to download the update (not from the App Store, directly from Software Update) I canceled the download halfway. I've tried to download the update again, but after it's downloaded, it shows "About 30 minutes remaining" but it gets stuck and doesn't install the downloaded update.

I have tried so many solutions, including booting into Safe Mode, but still the same result.

Even after 12.6 was released, I tried to update it, but I still get the same result.

Now I'm thinking that the file of the initial download I canceled is still located in my Mac but I don't know where, and I believe that's what's preventing the update from installing.

I've tried downloading the updates, both 12.5.1 and 12.6 over 7 times and I believe all these files are piled up in my storage.

Please how can I locate these files and delete them?

I've checked my "Applications" folder, but I can't find it. I also tried doing sudo rm -rf Install\ macOS\ Monterey.app/ in Terminal but to no avail.

Please do anyone know how I can delete these files and delete them?

1 Answer 1


Update to original answer

I've tried looking through my own posts at forums and found out I actually have managed to find most of bloat left by unsuccessful update! Directories used by softwareupdate tool and that never get purged are:

/Volumes/Macintosh HD/System/Volumes/Update/mnt1
/Volumes/Macintosh HD/System/Volumes/Update/software.update*
/Volumes/Macintosh HD/System/Library/AssetsV2/com_apple_MobileAsset_MacSoftwareUpdate/

So you'll have tocheck and purge them using Terminal in macOS Recovery as well. Also regarding failed update error description mentioned in original answer's quote. I never found explanation besides MCU 1130 Failed to seal system volume error in /Volumes/Macintosh HD/Volumes/Update/last_update_result.plist. Perhaps Monterey got better in logging errors so it's worth checking this log file.

Original answer

Check size of this folder: Volumes/Macintosh HD/System/Library/AssetsV2/com_apple_MobileAsset_MacSoftwareUpdate

Also check the actual free space of your Mac's main volume.

TL;DR your best bet will be to:

  1. Turn off automatic updates in Settings > Software Update
  2. Delete contents of com_apple_MobileAsset_MacSoftwareUpdate (if there are any and the size is significant), use Terminal in macOS Recovery with rm -rf Volumes/Macintosh HD/System/Library/AssetsV2/com_apple_MobileAsset_MacSoftwareUpdate/<Random-ID> (edit x's to actual large folder names) but make sure to diskutil mount diskXsX first (use diskutil list to check volume's mount point)
  3. Free up space on main Macintosh HD volume to a minimum required disk space for fresh macOS Monterey installation which happens to be 44 GB
  4. Check for updates manually via Settings > Software Update, download and run in manually, let update process run until it succeeds or an error/fail message appears (it can take 30-45 minutes easily even on SSD, don't pay attention to status indicator because it's lagging).

If you're extremely low on disk space you can try the steps with 26 GB of free space (this might work according to previous link). Hope this helps!

I'll keep the explanation brief - but believe me I struggled with similar thing literally for weeks - and this might be situation similar to yours. macOS's software update on Big Sur and up requires a lot of free space to install update. And if update starts installing it may check available free space wrongly, as a result update fails during installation but macOS snapshot prepared by Software Update doesn't get deleted, as well as some update files (I couldn't determine the location of that additional bloat of backups of backups). I learned all that while tried updating clean macOS Big Sur on a volume that was resized to smaller than minimum recommended size (34 GB while 35.5 GB was a requirement) and I almost managed to do this: my update process was starting and running for 99% making all preparations despite the space requirement was not met, free space was being filled with snapshots and other bloat, but 30 sec to the end update process failed with literally no explanation. As the result only the firmware was updated. You can examine this post for log of my struggle.

Good thing to know once update succeeds it will most likely remove traces of unsuccessful attempts. However IMHO it's the best practice to write down disk space usage before checking for updates and installing them (since you can easily loose 10+GB of disk space for some update that fails silently).

Please comment if you'll achieve your goal!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .