My 5 year-old iMac has been a rock - until yesterday. Suddenly, it became extremely sluggish with nothing but spinning wheels & beach balls. Even closing an app required 5 minutes or more. I finally managed to shut down & reboot.

The reboot seemed a normal pace, but afterwards, login was excruciatingly slow. After an approx 5 minute login process, I ran Activity Monitor to see if perhaps the dreaded BitDefender has commandeered all resources, but there was very little resource utilization for any process shown in AM!

This felt like a HDD problem, so I ran First Aid w/ Disk Utility on Macintosh HD from the Volumes view. It concluded with a green checkmark & Operation successful after checking 18 snapshots (?! what??).

I then switched to Device view & ran First Aid on Fusion Drive, Container disk4 and Macintosh HD (again). In all 3 cases, First Aid reported: green checkmark & Operation successful.

Continuing on to the Disk Images (Apple disk image Media & macOS Base System), First Aid again reported green checkmark & Operation successful.

These results seem to indicate that all is well, no? However, an odd thing (to me) was that Disk Utility (Volumes view) reports a 2.12TB HDD (APFS) for Macintosh HD, but the macOS Base System reports only 2.01GB w/ 1.28GB used & 733 MB free. Switching to Devices view shows a "Fusion Drive" of 2.12TB, a "Container disk4" with 2.12TB consisting of:

  • Macintosh HD (163.3GB)
  • 3 Not Mounted (11.63GB)
  • Free (1.95TB)

After all of this, it still feels like a HDD issue, but I cannot even guess what it might be. I'm puzzled by the fact that only 2GB of a 2TB drive are allocated to Macintosh HD - Why??. I've changed nothing on this machine; it's used almost exclusively by my partner who emphatically claims she's not changed anything - and I'm sure that's true.

I've looked through all of the "similar questions". I've run the "Diagnostics" (holding down the D key), but this effort seemed useless & inspired no confidence. About 1/3 through the Diagnostic process with 2 minutes (of the initial estimated 3 minutes) remaining, the "diagnostics" declared that everything is OK :O But it's not OK! The diagnostics then led me to a reboot, claiming that I'd go to Safari which would give me "options" for further troubleshooting led to a boot, but upon reaching Safari & clicking on "A" for Apple, I get marketing BS about a new iPhone!

Given that none of the answers to the similar questions were selected as correct, I don't expect a "silver bullet" answer here. However, I do hope that someone might offer an explanation of a 2GB Macintosh HD on a 2TB Fusion Drive, and perhaps suggest another line of troubleshooting to pursue. The sudden onset of major dysfunction is baffling to me.

EDIT 1; 9/17/22

A screenshot from: Apple menu  > About This Mac, then click Storage:

enter image description here

EDIT 2; 9/18/22

$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk2         121.1 GB   disk0s2

/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *2.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                 Apple_APFS Container disk2         2.0 TB     disk1s2

/dev/disk2 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +2.1 TB     disk2
                                 Physical Stores disk0s2, disk1s2
   1:                APFS Volume Macintosh HD            155.3 GB   disk2s1
   2:                APFS Volume Preboot                 42.2 MB    disk2s2
   3:                APFS Volume Recovery                510.6 MB   disk2s3
   4:                APFS Volume VM                      3.2 GB     disk2s4

$ diskutil cs list
No CoreStorage logical volume groups found

EDIT 3; 9/21/22

Since my last edit, I've installed DriveDx to help troubleshoot the suspected issues with my Fusion Drive. Based on the results from DriveDx, I believe the Fusion Drive is the source of my issues.

A visit to IFIXIT revealed two facts:

  1. Apple gave no thought to maintenance of the iMac - or if they did, that thought was directed at how to impede customer-performed maintenance!

  2. Mortals like myself should take heed, and outsource HDD replacement! Consequently, I made an appointment with the local "Apple Store" to have the problem remedied by one of their "Geniuses".

Unfortunately, my appointment with the "Genius" took 3 hours out of my life, but yielded no repair and no real solution. A nice enough fellow, but as a "genius" he came up a bit short (as I understand the meaning of this word). After 2+ hours of running tests, the "Genius" was unable to diagnose the problem, and offered only one "solution": "Buy a new iMac".

<rant>What a great company Apple is: Their "solution" to failure of a HDD in their 5 yr-old computer is to condemn the entire machine to a landfill. Meanwhile, they simultaneously make suspect claims about how environmentally friendly their products are. With "friends" like these - who needs enemies?</rant>

Up next: IFIXIT has some detailed guides for replacing the Fusion Drive. After perusing a few of them now, it's clear (but not easy) on how to remove the SSD component of Apple's ill-conceived Fusion Drive. It also seems that Apple's APFS does not (effectively) support conventional (rotating disk) HDDs - meaning that the HDD component of Apple's Fusion Drive must be replaced with a SSD. What is not yet clear is exactly how to get Apple's OS (Mojave in this case) to adapt to a single SSD. Any thoughts on this would be appreciated - a complete answer so much the better!

  • 1
    It feels like the Fusion has either become dissociated or the SSD has died. If it dissociates, it should show as two separate devices, though, so I'm not sure. Have a look at support.apple.com/HT207584
    – Tetsujin
    Sep 17, 2022 at 15:16
  • Dont forget to make a backup before you troubleshoot any further. Do you have a spare drive where you could install macOS and see whether it is a drive failure?
    – X_841
    Sep 17, 2022 at 15:31
  • @X_841: No spare drives - at least not a "Fusion" drive.
    – Seamus
    Sep 17, 2022 at 21:26
  • @Tetsujin: I've edited my question to add the screenshot I was able to get. It does say Fusion Drive, but it also shows Macintosh HD separately. What does this mean? Whatever it is - it doesn't look good. I wonder why Apple decided not to pass along the wear-leveling warnings it was getting from the SSD?
    – Seamus
    Sep 17, 2022 at 23:13
  • @Seamus you dont need a spare Fusion Drive. Any drive (HDD or SSD, theoretically even a USB pen drive but that will be extremely slow) is fine.
    – X_841
    Sep 18, 2022 at 7:55

1 Answer 1


After a fair amount of research, and with the help of the DriveDx tool I've determined that this "sudden onset sluggishness" was caused by a failure (wearout) of the SSD component of Apple's Fusion Drive. FWIW, there's a good summary of the Fusion Drive in the ArchLinux documentation.

There are postings on the Internet suggesting that the Fusion Drive was a poorly-executed design; I feel this one explains the situation fairly well. The Fusion Drive was Apple's attempt to create a low-cost, high-performance hybrid drive by pairing a lower cost & performance HDD with a higher cost & performance SSD. Not an inherently bad idea, but Apple executed poorly: they sacrificed service life for additional profit by specifying an SSD that was too-small. The too-small SSD was pounded with write cycles spread over too few memory cells; this resulted in premature death of many Fusion Drives. Mine was almost 5 years old, but very lightly used. Apple no longer produces the Fusion Drive.

Apple made things worse by cutting off logistical support. Fusion Drive repair parts are not available from Apple, and Apple will not accept "vintage" models for repair. Even worse, Apple manufactured Fusion Drives over the years with proprietary designs and hardware changes, effectively making 3rd-party solutions unreliable or, for some models, unavailable. On a positive note, it's good to know how Apple operates - you can set your expectations properly.

If you're not keen on relegating your over-priced Apple hardware to a landfill, there is some "good news" - depending upon which model you have. For iMacs, the IFIXIT website has detailed procedures explaining how to open the iMac housing, and access both the HDD and the SSD.

But of course gaining access to the failed parts is only half the battle. The HDD is an industry standard unit with the common SATA interface, but depending upon your model, you may face challenges finding a suitable replacement. I thought I'd found a good option in OWC's "Aura Pro X2 SSDs", but arriving at the order page I found a note stating that the Aura Pro devices weren't compatible with my late-2015 iMac:

an incompatible model

An alternative was suggested by the helpful folks at IFIXIT: beetstech sells replacement parts salvaged from other Macs; I've decided on this as the replacement part for my SSD. Contact beetstech directly to find a replacement for your model. EDIT: Beetstech has subsequently proven themselves to be un-reputable and dishonest; you should avoid them.

In Summary:

The Remove & Replace operation for the iMac's Fusion Drive is a rather tedious operation requiring special tools, cutting and replacing adhesive tape, etc. Finding compatible replacement parts may be even more tedious. But it is possible. I'll be sending a thank-you note to Apple when I get this completed - thanking them for showing me that right-to-repair laws may be useful for Apple's former customers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .