1

I am trying to cut and paste text but the iTerm popup keeps impeding me. This is due to iTerm and not generally on macOS since I have set the lower right corner as context-menu /right click but I'm dragging on the left side of the trackpad.

This behavior is happening regularly and is quite aggravating. Is there an way to disable the popup ?

Details: I put one finger down, then the other and drag it. But there is an annoying couple second delay and then the popup instead of selecting text.

enter image description here

2
  • What's your cut/paste method? I'm trying to figure out how that would invoke a right click.
    – Tetsujin
    Commented Sep 15, 2022 at 8:44
  • i'll add details Commented Sep 15, 2022 at 8:57

2 Answers 2

1

I had a similar issue with the Context Menu key on my external keyboard, were it was pulling up random commands from my history in iTerm2. Sometimes I would accidentally hit that key and it started to get annoying so I fixed it.

What I did was:

  • go to the iTerm2 Settings window
  • in the Keys tab > Press +
  • Click Click to Set
  • Press the Context Menu key
  • Set it to Ignore > Click the OK button

Since your Paste shortcut is the Context Menu key + Right Click, maybe it will still work for you? I am curious now. Please let me know if you try it.

My context: I only use a Mac for work and I am by no means an OSX expert.

1
  • 1
    Nice answer. I'm not sure how to "press the Context Menu key". I'm actually curious if such a key even exists by default in macOS: i need to use the trackpad to do it presently Commented Aug 10, 2023 at 17:43
0

Looks like it is an advanced setting 'dictionary' lookup

enter image description here

I set it to no . I am v skeptical of the decision to make this default to yes given how much aggravation it has been.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .