I know there's been a lot of these issues in the past, but here's mine (which seems a little bit different).

I have a MacBook Pro 2019 (Intel-based) and two monitors attached to it: one 1080p plugged from HDMI with a Satechi Adapter going into one Thunderbolt port (working just fine). I have another LG Ultra HD 24 inch monitor plugged via Display Port to an adapter Display Port-USB-C into another Thunderbolt port.

For months this setup worked just fine. My LG Monitor showed the native resolution (3840 x 2160) scaled to 1080p at 60hz and the other one at the normal 1080p native. I was happy.

But suddenly the setup stopped working. I didn't do anything. I didn't even update macOS. Now my 4K monitor is recognized as a 30.5 inch monitor with a native resolution of 1080 by the OS, and I can't seem to get it to full resolution.

To make this weirder, I have another MacBook Pro at home (2020, Intel too). Same result. One is Big Sur, the other one Monterey. Both are having the same issue.

Image 1 Image 2

Here's what I've done so far, reading other people's similar issues:

  1. Disconnected and reconnnected the monitors in every fashion possible.
  2. Reboot in safe boot to get to the problem.
  3. Of course, I've pressed opt to see if there're other resolutions.
  4. I've connected the monitor with Display Port to other (Windows) computers and even my own iPad Air. Monitor, cable and adapter working just fine with every other device except both my MacBooks.
  5. Updated my Big Sur MacBook to the latest Monterey.
  6. Cleaned up the PRAM and the other one I don't remember the name (lol).

Nothing has worked so far. I'm running out of options here. Any suggestion?

PS: If I change Display Port to HDMI I get 4k with 1080p scaling, but only at 30hz. Seems a good way to go for now, but it doesn't quite solve my problem.

2 Answers 2


I got it working again. I just needed to buy a DP to USB-C (Thunderbolt) cable.

Why it stopped working with the adapter all of the sudden, I have no idea, but buying a cable that doesn't need an adapter seems to solve the problem.


I had an issue when I set up my new adapter Baseus, and I also have an LG monitor. It worked just fine at first, then the resolution dropped to 1920 x 1080.

I have HDMI-HDMI cable from the monitor to adapter and USBC-USBC adapter-mac. I unplugged HDMI-HDMI and plugged it back switched sides, and this helped somehow.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .