I keep getting a notification

Exchange Password Required
Enter your password for "emailaccount" in Internet Accounts.

in the top right of my screen and it doesn't disappear on its own. If I click its close button it will reappear within a few minutes.

I don't want to enter the password for this account, because on dodgy wifi or constantly changing internet connectivity situations, it will always log itself out again or cause some problem that makes this prompt return.

I just want to stop the prompt automatically appearing.

I will reenter the password when I feel the necessity to use that account again.

How do I stop this notification from appearing? How to ignore this status?

  • Have you tried Disabling the account? There's a checkbox in Mail Settings > Accounts.
    – Ezekiel
    Commented Sep 11, 2022 at 22:44
  • @Ezekiel that didn't work
    – minseong
    Commented Sep 13, 2022 at 6:51

3 Answers 3


Stop Mail auto-fetching.

enter image description here

Image from Mojave, but it hasn't changed much since.

  • Can I change that for only this one mail account?
    – minseong
    Commented Sep 11, 2022 at 18:16
  • Not as far as I'm aware, it's global.
    – Tetsujin
    Commented Sep 11, 2022 at 18:17

Prevent Apple from automatically checking for mail from this account.

Settings page

Again, this is a printscreen from an older Mac version. If you un-check that checkbox, then this account's mail would not be fetched automatically, but you can always fetch it by hand when you are ready for it.

  • 1
    This option does not exist in the most recent Mac version unfortunately
    – Undead
    Commented Oct 31, 2022 at 19:37
  • Ah, I see, all these "upgrades"... No wonder Microsoft was charging people a "Downgrade Fee" when they wanted to have XP instead of Vista... :)
    – Alex
    Commented Nov 2, 2022 at 0:29

Open up your Apple "Mail" software, to go to Settings=>Accounts..., find the specific account which is giving you grief, and un-check the Enable this account option:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .