0

Currently I am using a Windows VM so that I can use PUTTY to SSH into a device that is connected through a USB port to my MAC. This works fine. However, I am unable to SSH into the device on MacOS through iterm2 - I suspect that it is because the network settings aren't what they are supposed to be. When I plug the device into my thunderbolt adapter on my Mac and run my Windows VM the device shows up perfectly fine and creates a new network in Windows:

In Windows this happens

However, on MacOS Thunderbolt bridge seems to be stuck on "inactive": (ignore the subnet mask mismatch, I have tried with 255.255.0.0 too)

enter image description here

Checking the MAC address of the Thunderbolt Bridge and looking at the settings in ifconfig:

bridge0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=63<RXCSUM,TXCSUM,TSO4,TSO6>
ether e2:74:33:e3:a6:c1
inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
inet6 fe80::14a7:af36:419d:645c%bridge0 prefixlen 64 secured scopeid 0xd
Configuration:
    id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
    maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
    root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
    ipfilter disabled flags 0x0
member: en3 flags=3<LEARNING,DISCOVER>
        ifmaxaddr 0 port 11 priority 0 path cost 0
member: en4 flags=3<LEARNING,DISCOVER>
        ifmaxaddr 0 port 12 priority 0 path cost 0
member: en12 flags=3<LEARNING,DISCOVER>
        ifmaxaddr 0 port 10 priority 0 path cost 0
member: en13 flags=3<LEARNING,DISCOVER>
        ifmaxaddr 0 port 9 priority 0 path cost 0
nd6 options=201<PERFORMNUD,DAD>
media: <unknown type>
status: inactive

This is clearly a software issue as the port works fine in the Windows VM but for some reason networking seems to be far more complicated on Mac.

How do I replicate the Windows behavior on MacOS? I want the wifi connected to the internet, and I want a separate LAN connection through the USB cable to my device so that I can ssh into it. The device is not connected to the internet.

My .ssh/config file:

Host inst
    HostName 192.168.137.2
    BindInterface bridge0
    User testuser
    IdentityFile ~/.ssh/id_rsa_testuser
    Port 22
    IdentitiesOnly=yes

$ssh -vvv inst

OpenSSH_8.1p1, LibreSSL 2.7.3
debug1: Reading configuration data /Users/westman/.ssh/config
debug1: /Users/westman/.ssh/config line 7: Applying options for inst
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 54: Applying options for *
debug2: resolve_canonicalize: hostname 192.168.137.2 is address
debug2: ssh_connect_direct
debug1: Connecting to 192.168.137.2 [192.168.137.2] port 22.
debug1: ssh_create_socket: bound to 192.168.2.1
debug1: connect to address 192.168.137.2 port 22: Operation timed out
ssh: connect to host 192.168.137.2 port 22: Operation timed out

1 Answer 1

0

I think you have mixed some things up. I'm suspecting that you're not actually connecting your computer to Thunderbolt-equipment - and as such ofcourse the Thunderbolt bridge won't be activated in that case.

I would suggest that you look the Device Manager in Windows, where you can see the network interface. My guess is that the device is actually just a USB network adapter (i.e. it acts as such) and you will need to install the appropriate driver on macOS, depending on whether the device uses RNDIS, ECM, EEM or NCM (all over USB).

You have included information about your SSH setup. I would suggest using something simpler like "ping" to test connectivity first. The SSH information suggests that you might be simply trying to connect a Raspberry Pi or similar (i.e. the device is actually just a Linux computer) - in that case it is not the Thunderbolt bridge you want - it is a USB networking interface (implemented using the Linux gadget system).

8
  • Your assumptions are indeed correct. It IS a Linux device running a custom distro and it IS connected through RNDIS. I did some googling and found something called HoRNDIS but it seems depreciated - doesn't work for Big Sur. Are you aware of any RNDIS drivers?
    – Westman
    Sep 8, 2022 at 14:00
  • Can't you setup your Linux device to use something different than RNDIS? - That seems to be the easiest option. RNDIS is Microsoft proprietary, but there's a number of other, non-proprietary, networking over USB options.
    – jksoegaard
    Sep 8, 2022 at 15:11
  • I can't do that - this isn't my private device. This is a commercial device. It's not up to me to choose which protocols we use, unfortunately.
    – Westman
    Sep 12, 2022 at 10:35
  • It is difficult to help you without knowing what the device is. Are you not allowed to tell us which device it is? - I assume the device came with some vendor instructions - did they tell you that macOS is supported? If not, they have probably just went with the Microsoft proprietary interface and said Windows-only. Then I would buy a different product that does support macOS.
    – jksoegaard
    Sep 12, 2022 at 10:38
  • I can't pick a different product as this is the product that we sell. I wanted to SSH into it through Mac because I'm used to working on Mac. I'm just gonna have to use my Ubuntu VM. Thanks for the help anyway!
    – Westman
    Sep 12, 2022 at 11:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .