My iPod Touch 4G got stuck while syncing with iTunes on a Mac Mini. I canceled the sync using the slider on the iPod but "Canceling sync" remained on the screen. I was able to open some apps, but Music would not launch. I tried to restart the iPod and now it just shows the Apple logo and is stuck on a progress bar. It cannot be rebooted.

Now it only connects with iPhoto, it is possible to import images. But when connecting to iTunes the progress bar is turning around and no content appears.

Is there a way to fix this? Thank you for your help.

3 Answers 3


Try restoring in device firmware upgrade (DFU) mode. Just google "DFU restore" and this should give you the instructions that you need.

  • @Michiel Thanks all of you guys. Finally this helped: Turn off iPod -> hold Home -> connect USB -> download new firmware (or entire iOS? - the file has 750 MB). It freezed again after download so I went back to DFU mode and repeated the procedure. This time it restored.
    – Beek
    Mar 20, 2012 at 15:55

First try to simply reboot your iPod and retry sync.

If you still have the same problem maybe the media database on the iPod is corrupted/broken try to uncheck sync Music, sync Movies, Sync TV Shows, Sync Podcasts and Sync iTunes U.

Uncheck sync Music Uncheck sync Movies ...

Then sync

Once the sync is done recheck the sections you want to sync and sync again.

If this still doesn't work reconnect your iPod to the computer. Interupt any sync that could be starting.

Then restore the iPod.

Restore the iPod

Follow this procedure.

At the end of the procedure you can chose to restore from a backup. If that works, it's fine.

If restoring from the backup doesn't work. Then retry this procedure and at the end choose to setup a new iPod instead of restoring from a backup.

If you cannot do any of the above. Or if it doesn't work the next step is to try recovery mode.This answer explains how to put your device into recovery mode.

Once in recovery restore your iPod with the latest available firmware.

Once this is done you can try to restore your device from backup... If restoring from backup doesn't work again try this procedure and setup a new iPod.

The last resort solution is the DFU mode. Setup you device to DFU mode as described in the same answer as for recovery mode.

Once this is done again you can try to restore your device from backup... If restoring from backup doesn't work again try this procedure again and setup a new iPod.


Have you tried to reset your iPod?

Press and hold the Sleep/Wake button and the Home button together for at least ten seconds, until the Apple logo appears.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .