3

I have a strange error occurring with a 13 inch retina 2018 MacBook Air.

Upon boot, I see the white apple logo and progress bar, and then the user accounts to log in. At this screen, I have about three to five seconds before the screen goes black. The computer is still responsive; the keyboard is still lit, and I can still click and type -- the screen just displays nothing but black. When I close and reopen the lid, with maybe about 75% consistency, the screen reappears, but then I have again about five seconds tops before it goes black again. Rarely, the screen isn't entirely black -- the very top row of pixels on the screen is lit, though it's hard to tell if they're displaying what they should be or just lighting randomly, since it's a single row of pixels.

External displays don't go black, allowing me to confirm that the computer is indeed still responsive.

I have tried several things:

  • rebooting
  • resetting NVRAM/PRAM multiple times
  • running Disk Utility in macOS recovery (no errors found)
  • running in safe mode -- this one worked! The screen never went black in safe mode. But it is not sustainable to always run in safe mode.
  • reinstalling macOS
  • factory resetting -- "Erase All Content and Settings" in System Preferences

I'm confused because I can't even really diagnose the problem. The fact that safe mode, booting, external displays, etc all work fine suggests to me that this isn't a hardware issue, but the fact that even a factory reset didn't fix it seems to suggest that it's not a software issue either. So I'm quite confused.

Google isn't helping much either -- while I can find links which talk about a black screen problem (which is where I found some of the fixes I tried above), I haven't yet found one that talks about a screen which works for specific situations (booting, first five seconds, safe mode, etc) but then cuts to black.

I am looking for ways to fix the problem, or even just ways to diagnose what the problem is.

2 Answers 2

1

Safe Mode results are the clue here.

There is something that you installed that is doing this (something that runs at startup.)

OR Some part of macOS is damaged. Reinstalling the same macOS version right over top of the currently installed OS should fix that issue. And doing that should result in no loss of files and/or settings. But to be sure backup the drive first.

3
  • Hi @SteveChambers, thanks for your answer. As per my post I've tried reinstalling macOS and wiping the computer, and neither repaired the problem. That leads me to believe it's not something that the owner installed, nor is macOS damaged (unless the reinstall was damaged too, I suppose). Does this affect your answer, and if not, could you elaborate on why?
    – Eric
    Commented Sep 5, 2022 at 22:20
  • Hi again @SteveChambers, in the interest of giving you the benefit of the doubt, I reinstalled macOS again, and confirmed that no programs run on startup (System Preferences > Users & Groups > Login Items). The screen still goes black in the way described. Unless I am doing something incorrectly, I'm not sure that this fixes the issue.
    – Eric
    Commented Sep 6, 2022 at 0:46
  • 2
    A fresh reinstall of the OS and the same symptoms leave one conclusion: a hardware issue. Commented Sep 6, 2022 at 20:56
0

Launch agents and launch daemons are loaded by macOS at startup, but do not appear in the "Login Items" list.

When you started the Mac in Safe Mode, the screen didn't go black because whatever-it-is that causes the video failure wasn't loaded. You will need to find the offending software, and delete it.

This MacWord article discusses this issue:

Since OS 10.4 Tiger, Apple has given developers another mechanism for launching items automatically: launch daemons and agents that are controlled by the launchd process. This provides more flexibility for developers but it is less transparent to users.

Instead of opening apps directly, launchd loads specially-formatted .plist documents that specify what should launch and under what circumstances. Sometimes these launch items run constantly in the background, sometimes they run at scheduled intervals, and sometimes they run as needed—for example, in response to an event such as a change in a certain file or folder—and then quit.

The .plist files that launchd uses can occupy any of five folders, and their location determines when the items load and with what privileges:

  • Items in /Library/LaunchDaemons and /System/Library/LaunchDaemons load when your Mac starts up, and run as the root user.

  • Items in /Library/LaunchAgents and /System/Library/LaunchAgents load when any user logs in, and run as that user.

  • Items in /Users/your-username/Library/LaunchAgents load only when that particular user logs in, and run as that user.

Don’t change System files: Of those five folders, the two located in the /System folder (/System/Library/LaunchDaemons and /System/Library/LaunchAgents) are for components included as part of macOS, and you should resist the temptation to remove or alter them—they’re essential to keep your Mac running correctly.

  • Modify others as you like: Feel free to browse through the files in the other folders to see what’s there. You can modify them—for instance, to disable them or to change how often they run—but before you do, you should understand a few things about how they work.

When you start your Mac or log in, the launch items in the relevant folders are loaded (that is, registered with the system) unless they have a Disabled flag set. Thereafter, their instructions will be carried out until you restart, even if you drag the launch item to the Trash. To see a list of all the currently loaded launch items on your Mac, open Terminal (in /Applications/Utilities) and type launchctl list and then press Return.

If you want to stop a launch item from running without your having to restart, open Terminal and type launchctl unload followed by a space and the full path to the launch item. An easy way to add an item’s full path is to drag it to the Terminal window) For example, take this command:

launchctl unload ~/Library/LaunchAgents/com.apple.FolderActions.enabled.plist

It unloads the launch agent that enables AppleScript folder actions. Repeat the command with load instead of unload to turn it back on.

Because most launch items run on a schedule or on demand, and because any of them could be disabled, the fact that something is present in one folder doesn’t necessarily mean the process it governs is currently running. To see what’s running at the moment, open Activity Monitor—but bear in mind that the name of a given process as shown in Activity Monitor might not resemble the name of the .plist file that tells macOS to launch it.

Other explanations for mystery processes

Although these methods are the most common ways to launch apps automatically in macOS, they aren’t the only ones. If you have a mystery process that you can’t track down in any of these places, it could also be one of these:

Kernel extensions: Kernel extensions, or kexts, live in /System/Library/Extensions and load at startup. They provide low-level features such as processing audio and adding support for peripherals. Most kexts on your Mac are part of macOS. The safest way to remove a third-party kext is to run an uninstaller provided by the developer.

Crons: Cron is a Unix scheduling utility built into macOS. It’s more-or-less not used anymore in favor of launchd, but you never know what might be lingering on a Mac that has gone through a lot of updates or is running old software.

Login scripts: Login scripts, like startup items, were used in older versions of macOS but are now deprecated.

1
  • Hi @David, as per my post, the computer has been wiped clean via "Erase All Content and Settings" in System Preferences. That means to my knowledge there are no non-default programs installed, and thus there is nothing running on startup except for default macOS behavior (unless I misunderstand and a program could persist beyond this reset -- is that possible?). I further confirmed that the folders /Library/LaunchDaemons and /Library/LaunchAgents are empty. Per the link advice, I did not alter the System files, so there may be a problem there, but I would need further help to diagnose it.
    – Eric
    Commented Sep 6, 2022 at 2:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .