5

I've just bought the Ipad 2, all my existing passwords that I need to use (mails web services etc) are in Arabic characters.

I have added the Arabic Keyboard and am able to use it in normal text fields, but I cannot switch to it when I try to type into a password field. If I already have the Arabic keyboard selected when typing a username, it switches back to the normal keyboard when I move to the password field. Because of this I am unable to log into anything which uses an Arabic password.

I tried with Safari and Opera Mini browser.

Does anyone know how to fix this?

  • My guess is that due to the calligraphic nature of Arabic text, it's hard for the system to decide exactly what constitutes a "character" for the hiding-passwords-with-bullets feature. However, the more I think about that, the less likely it seems! – Timothy Mueller-Harder Mar 20 '12 at 11:25
2

I can see that this is likely to be very restrictive until you find a solution, so I offer this workaround to ease things while other answers come in. If you enter your password into your username field, then select it, copy it, and type over the top with your actual user name, you can then paste the password into the password field.. This is 3 extra taps overall, but will at least allow you to use your logins in the meantime.

| improve this answer | |
0

I am using copy paste now, and using google keyboard. But you cannot change the password keyboard. It seems locked.

So if your password has characters otherwise found on a google keyboard, you won't be able to type it into a password field. Copy paste is the best solution i found, so type it in the username text box or somewhere else using google keyboard and copy it over.

| improve this answer | |
  • Any custom keyboard has access to any characters you type (obviously). There are good reasons why you don't want to give your passwords to 3rd party keyboards :-) – nohillside May 18 at 10:08
  • Im using a google keyboard, i migrated from android. Likewise non 3rd party keyboards also have access to my password, obviously. – Ken May 19 at 9:34
  • The OS and the keyboards it supplies have access to anything anyway – nohillside May 19 at 9:55
  • I find the iOS keyboard not intuitive, ie if i want to place a cursor in the middle of a word, i have to hold down space, I also have to know where all the hidden keys would be, ie if looking for ` i need to know to long press the key that looks the same but is point in the opposite direction. Will have to try get used to it and learn Apples way of doing things. – Ken May 19 at 10:12
-1

Have you tried hitting this key?

enter image description here

Or you can try this free app which will allow you to use an Arabic keyboard on your iPad.

EDIT:
Here is a great walk trough on how to do this...

| improve this answer | |
  • 1
    the key doesn't show up when typing a password, this is the problem – sohaibafifi Mar 20 '12 at 9:26
  • Have you selected multiple languages in Settings < Keyboard < International (I'm not 100% of the naming since I don't have an English iDevice with me at the moment) – Michiel Mar 20 '12 at 9:28
  • I have already the Arabic keyboard layout on the system, I'm using Ipad2 so no need to this app in my case – sohaibafifi Mar 20 '12 at 9:30
  • Yes i have both English and Arabic keyboards added – sohaibafifi Mar 20 '12 at 9:32
  • 1
    @Michiel Do YOU see the globe key when you are in a password field? – Tom Gewecke Mar 20 '12 at 13:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .