1

I'm trying to get the fzf directory switcher to work in my terminal (Hyper).

It is supposed to work using option-c but in my case that just enters a cedille (ç).

One workaround I found is to use Esc-c instead.

How can I fix this?

1 Answer 1

1

You need to use a “meta” or “alt” modifier, which Mac doesn't have natively. Hyper (like most Mac terminal emulators) can be configured to use the ⌥option or ⌘command key as a meta key. Open the configuration file (you can do this from Hyper with the “Hyper” > “Preferences” menu entry). There, look for the config: { … } block. If there isn't already one, add a nested modifierKeys block. To make ⌥option act as a meta modifier in Hyper instead of having its usual “alternative character” meaning, set the altIsMeta boolean option.

"use strict";
// Future versions of Hyper may add additional config options,
// which will not automatically be merged into this file.
// See https://hyper.is#cfg for all currently supported options.
module.exports = {
    config: {
        modifierKeys: {
            altIsMeta: true,
        },
        …
    },
    …
};

Hyper has a bug whereby this doesn't work correctly for dead keys. For example, with a US keyboard, this makes ⌥+c equivalent to Esc c, but ⌥+e keeps its dead key function in addition to its Meta+E function, so ⌥+e a is equivalent to Meta+E and then inserting á.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .