All of the sudden my 2013 iMac on Catalina ran out of space. Last time I checked (last week), I'd about 400GB of space on my 1TB hard drive. Now the computer starts really slow and then it says I've -43Mb (yes, with a minus sign).

I think the problem is related to an update (I forgot to disable updates, every update is a mess). I'd Time Machine, but my wife had to back up her Windows computer in an emergency, so I lent her my external hard drive. When the update ran, there was no external hard drive connected, and last week I saw some messages about Time Machine errors (I don't remember where, though, because I freaked out and tried everything I could ).

Anyway, I deleted a lot of files, and I mean at least 100 GB. Still the same problem. Also, when I use the System Information and then Space Administrator (maybe that's not the right name, I translate from Spanish, but it's the option Cmd+U), the Documents / Large Files option is empty, although it's 177.48 GB.

enter image description here

I'm going crazy and really don't know what to do. I've tried the software mentioned in "System" storage on macOS Sierra is 470GB! to no avail, because what I delete doesn't really get deleted, it just disappears.

I'm watching closely and I see it's creating files (or something) at a 30MB/s rate. So I deleted almost 2GB and a couple minutes later I ran out of space. So it seems there's some process or soemthing that's causing this behavior

Does anyone have any idea what I can do or how I can find (and delete) these "ghost" files?

  • Can you wait until the loading process finishes ("Calculando" in the left tab) and reupload
    – X_841
    Commented Aug 29, 2022 at 15:45
  • Have you restarted the computer? Sometimes the OS needs to "rescan" the drive to see what's there and "not there". This may fall into the category of "Purgeable space" and may take some time. An alternative is to use an app such as DaisyDisk to clear out the purgeable space.
    – agarza
    Commented Aug 29, 2022 at 15:46
  • @X_841 done, you can see the 730Gb used by "other"
    – Devin
    Commented Aug 29, 2022 at 15:49
  • 1
    DaisyDisk costs money: OmniDiskSweeper is free. omnigroup.com/more
    – benwiggy
    Commented Aug 29, 2022 at 16:11
  • 1
    Also, OS updates should not normally cause problems - if they are, that may hint at some other underlying cause on your disk. "Updates are bad" is not a wise conclusion.
    – benwiggy
    Commented Aug 29, 2022 at 16:13

4 Answers 4


First of all, try disabling Time Machine, and erasing snapshots from your system.

Open the terminal, and type the following:

tmutil listlocalsnapshots 

sudo tmutil deletelocalsnapshots (Date on these snapshots)

Next step, clean the cache:


If there is still not enough space - install BuhoCleaner, select ToolKit ----> Disk Space Analyzer. It will show you the files that are taking up so much space.


Thank you everybody for your help. I tried the suggested apps and other methods I have found online, but nothing worked and it got to a point it wouldn'even boot anymore. I took it to the service.


I know this question is closed but I got exactly the same issue and I fixed running the following command:

sudo kextcache --clear-staging

are you using the 'photos' app? if so, have you checked the photos library? My friend had a similar issue, turns out his photos app was set to download full rez images to the drive and his library eventually was 800GB large.

If that is the case then go to photos -> preferences -> iCloud Tab and turn on 'optimization'. That should stop the library from 'growing'

  • personally I wouldn't use the Photos app, since it puts everything in one 'container'. Sure you can check the package contents but finding a picture in there is basically impossible.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .