I have an ORICO dual-bay SSD enclosure configured for RAID 1. I can't get it to mount on my personal 14" M1 MacBook Pro, but it mounts just fine on two other 16" M1 MacBook Pros.

All three systems are running macOS Monterey 12.5.

I don't even know where to start with troubleshooting this beyond what I've tried already, so I'm just going to list a bunch of facts that I have observed:

  • I just formatted the disk with all of the default settings (APFS and GUID partition map, volume name extssd) on one of the 16" MBPs. Everything worked fine on that machine.
  • I don't have any other external USB-C storage to test with, to see if it will mount on my 14" MBP.
  • The disk has never mounted or worked correctly on my 14" MBP. I chalked it up to some weirdness with the RAID enclosure, until I plugged it in to one of the 16" MBPs and observed that it worked as expected.
  • Sometimes, I can see the disk in Disk Utility on the 14" MBP. The volume name never shows up correctly. If I try to format it, it fails.
  • It does not matter which port I plug the enclosure into - I have tried all three - and it does not matter if I have any other devices plugged in or not.
  • The USB-C / Thunderbolt / whatever-they-are ports work just fine; I have a dock plugged in right now, and it's working fine. Unplugging the dock - even unplugging the dock and rebooting - makes no difference.
  • Plugging the SSD in to the dock also does not work. Sometimes it shows up in Disk Utility; sometimes it does not.
  • I'm using the USB-C cable that came with the enclosure. It has worked just fine on the other two 16" M1 MacBooks (even as of ten minutes ago), as well as on my old Surface Book 3 running Windows before I got rid of it a few months ago.
  • I have tried "turning it off and turning it back on again". Multiple times.
  • It doesn't matter if the machine is being powered by my USB-C dock; by battery power; or by the Apple MagSafe power brick - it exhibits this behavior regardless.

I just tried running First Aid on the disk, and it fails with this output:

Running First Aid on "ASMT ASM1352R-Safe Media" (disk5)
Fixing damaged partition map
POSIX reports: The operation couldn't be completed. Input/output error. : (5)

Operation failed...

I'm truly at a loss on this one, and I'd appreciate any and all assistance.

1 Answer 1

  • Try running diskutil list in Terminal to see if the drive is detected and the correct capacity is shown.
  • Check  > About This Mac > System Report > USB to see if the device's connection speed is the same as on the 16" Macs where it works.
  • Check Console for any additional connection-related errors when plugging in the drive.
  • Try another USB cable, and/or plug the USB-C connector flipped 180 degrees, just to be sure. (I have seen a wonky connector that was limited to USB2 speeds when plugged in the wrong way.)
  • To rule out possible software issues, you can boot into recovery (holding Cmd+R when turning on your Mac) and try connecting the drive then (checking if it shows up in Disk Utility and whether the input/output errors persist).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .