2

I've run through a range of solutions offered on the forum

The disk came from a Windows 10 machine and I wanted to wipe and install another OS but have been struggling. I gave up on the actual PC as I made little progress with USB boot tools. I got a SSD/USB mounting and can mount the drive on my Mac but when I use diskutil to reformat it I get the error:

"Wiping volume data to prevent future accidental probing failed. : (-69825)"

I thought the thread New SSD can't be initialized would be helpful, but following these instructions made no progress. And I tried following the instructions for Corrupted USB Drive - Unable to Partition or Erase Disk, but that failed as well following the suggestions of @klanomath.

When I look at the contents diskutil list:

 #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *256.1 GB   disk6
   1:                        EFI ⁨BOOT⁩                    1.1 GB     disk6s1
   2:         Microsoft Reserved ⁨⁩                        134.2 MB   disk6s2
   3:       Microsoft Basic Data ⁨⁩                        252.3 GB   disk6s3
   4:           Windows Recovery ⁨⁩                        2.6 GB     disk6s4

And gpt -r show:

start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34       2014         
       2048    2070528      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
    2072576     262144      2  GPT part - E3C9E316-0B5C-4DB8-817D-F92DF00215AE
    2334720  492783616      3  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
  495118336    4997120      4  GPT part - DE94BBA4-06D1-4D40-A16A-BFD50179D6AC
  500115456       2735     

I am at a loss. I don't need/want the data, I just want to use the drive to load back into the PC.

2 Answers 2

0

If you’re sure that disk6 is the one you want erased, here is the command. Warning, it will not ask permission and you’re not getting the data back easily or ever if disk 6 isn’t the correct target…

diskutil unmountDisk disk6
diskutil partitionDisk disk6 1 MBR FAT32 WINDOWS R

I’ve not had to zero the MBR, but that might be needed if you don't get an obvious error message from the two commands above. I don't have the same size disk, but here's what it looks like on Monterey:

bmike@m2 ~ % diskutil unmountDisk disk6
Unmount of all volumes on disk4 was successful
bmike@m2 ~ % diskutil partitionDisk disk6 1 MBR FAT32 WINDOWS R
Started partitioning on disk6
Unmounting disk
Creating the partition map
Waiting for partitions to activate
Formatting disk4s1 as MS-DOS (FAT32) with name WINDOWS
512 bytes per physical sector
/dev/rdisk6s1: 62519456 sectors in 1953733 FAT32 clusters (16384 bytes/cluster)
bps=512 spc=32 res=32 nft=2 mid=0xf8 spt=32 hds=255 hid=2048 drv=0x80 bsec=62550016 bspf=15264 rdcl=2 infs=1 bkbs=6
Mounting disk
Finished partitioning on disk4

Note, you need to allow terminal app to access removable drives, so if you denied that, open System Preferences and make sure you've granted access.

Allowing terminal to access removable media on macOS Monterey

3
  • Thanks @bmike I was hopeful but similar errors Step 1 worked no problem But Step 2 hung at 50% partitioning and eventually posted the same error Unmounting disk Creating the partition map Error: -69825: Wiping volume data to prevent future accidental probing failed
    – Obiwan
    Commented Aug 19, 2022 at 19:07
  • You have a hardware failure in most cases when these commands can not erase a drive. I wanted to cover the edge cases for permissions, but it’s the cable or the controller or the drive at this point @Obiwan - does the drive vendor offer a firmware upgrade or hardware diagnosis / warranty?
    – bmike
    Commented Aug 19, 2022 at 21:00
  • Thanks @bmike appreciate the help and additional commands. No warranty but I can get a replacement drive fro the laptop which is my lowest cost solution at this point
    – Obiwan
    Commented Aug 20, 2022 at 16:22
0

DD'ing the beginning of the drive in your terminal application should give you a nice solid wipe. If this command doesn't work, then you most likely have a broken hard drive. Open up your MacOS terminal application and...

  1. Find your disk identifier (ex: /dev/disk3) for the disk you want to wipe diskutil list
  2. Use the dd command to wipe the beginning sectors of your drive (this should only take a few seconds)
sudo dd if=/dev/zero of=/dev/disk_to_erase bs=1m count=30

an example (if your disk identifier is /dev/disk3) would be...

sudo dd if=/dev/zero of=/dev/disk3 bs=1m count=30
  1. Then eject your erased disk
diskutil eject /dev/erased_disk

as in

diskutil eject /dev/disk3

Reinsert your disk, and it should show up blank and unpartitioned in Mac OS.

5
  • I did what you said and i does all the steps but in the end the disk shows the same error when I try to format it. Commented Feb 21 at 19:57
  • Then you have a faulty disk. It's faulty hardware.
    – DanRan
    Commented Feb 27 at 3:21
  • FYI, you have to use the dd command from a different computer. Don't try to dd the same hard drive that is being used or running your OS. Plug your hard drive into your computer externally and use the DD command. If the dd command doesn't erase it, then you have a faulty disk with faulty hardware.
    – DanRan
    Commented Feb 27 at 3:23
  • yep, that obvious. I've purchased new external ssd. Commented Feb 28 at 10:07
  • @alexeypolusov Is the new drive working as expected? did you try the DD command on it before formatting it? Lastly, Could you please mark my answer as the accepted answer, because it is absolutely correct. Thanks. I really appreciate you doing that if you can.
    – DanRan
    Commented Mar 9 at 16:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .