1

I have tried to install XCode first via app store and then after downloading the file manually, via command xip --expand Xcode_13.4.1.xip. In both cases I got the same error relatie to missing space

xip: error: The archive “Xcode_13.4.1.xip” can’t be expanded because the selected volume doesn’t have enough free space.

The error is quite surpraising as on my hard drive there are still ~35 GB of space available. Following some online suggestion I also tried to create an empty file of ~20 GB with

dd if=/dev/urandom of=temp_20GB_file bs=1024 count=$[1024 * 1024 * 20]

and finally remove it, but it didn't work either.

I guess 35 GB should be enough space but I do not get why it cannot make it to install XCode. Any idea to workaround this?

3
  • I saw that but it does not suggest me anything.
    – Randomize
    Aug 18, 2022 at 13:54
  • 3
    The long & short is that you have to keep clearing space until it will fit. There's nothing else. If you're that short on drive space you really don't want to be filling it right up with Xcode anyway.
    – Tetsujin
    Aug 18, 2022 at 13:55

1 Answer 1

1

I have found a solution for my case, hope it helps other too.

I run from terminal:

du -sh -- Library/Caches/* | sort -rh | more

which sorted in order (biggest to smallest) the directories and I removed some of the biggest in my case like JetBrains and VisualStudio. When I rerun the command xip --expand ... this time worked (from the App Store still an error tho, but may be a restart could fix it although I am not going to use it).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .