1

Want to use good old iMac G4 (powerMac 6,1) with 10.4.11, after it sat in storage for years. Booted from original internal HDD and ran fine.

To expand storage, bought "compatible" OWC SSD with Startech interface board, removed original HDD per iFixit instructions, cloned to SSD, reinstalled and the iMac only boots to the folder/? and Macos icon. If I boot with Option key I get a reload and right arrow button icon only (Startup Manager?).

Tried to boot with C key and original install Disk using both internal and external CD drives, same result. Boot with D key for hardware test also gives ? Folder.

iMac starts in Target Disk Mode and I can see the SSD and its files.

All together, I tried cloning 3x, with CCC6, CCC5, and SuperDuper! 2.7.1, which should have produced a 'bootable clone' but same result.

I've used same basic process to update other Macs and it worked. What is going wrong here? The SSD is properly connected and has power to it since I can see it in Target Disk Mode. It's just not recognized by the computer on booting.

I had also inserted a new under-baseplate RAM module but removed it and replaced with original Apple RAM, same result.

Reset PRAM (new battery installed) several times, tried command R for recovery and shift for single user mode, same result. In frustration, I lightly swept my fingers over the keyboard and some text on a light screen came up offering I could type "mac-boot" or "shutdown" and enter, so I typed "mac-boot" and got again ?/Folder.

I'm not keen to take the iMac apart again, wondering if there is some startup step I should be doing or something I can do software wise from another device to make the SSD bootable.

I supposed worst case I can reinstall the original HDD and hope for the best, making regular backups for the day the nearly 20-year old HDD dies and then... But I am trying to find a way to see if the original HDD will boot the iMac via Firewire but haven't found in my boxes of old HDs an enclosure for it, so have no way to connect it now to try.

I hope someone has some ideas I can try to get this to work.

8
  • Pleas pay attention to the formatting of your question. Without paragraphs it is extremely difficult to follow. It would also help to state the detail of the question first before the long narrative. Itemise your aims, the steps you have taken and the results so far. Otherwise welcome to Ask Different! Commented Aug 17, 2022 at 12:43
  • @IconDaemon It's M8935LL/A iMac (17 inch Flat Panel, 1Ghz) 2003 or one of that family it seems. From MacTracker Commented Aug 17, 2022 at 12:48
  • Andy Griffiths, indeed, when I was writing the text in the text entry field I had used return characters and when I clicked to post the question it was all one big block, I totally get it about the readability, I used to work in newspaper journalism...
    – Dave N
    Commented Aug 17, 2022 at 15:07
  • Andy Griffiths, the baseplate says it's a Model M6498; EMC No. 1956; 1.0GHz/256MB/80HD if that helps. I have cloned again to a spare 2.5" HD that can connect via Firewire, I'll see if iMac boots from that and advise. Everymac site check of the SN told it is a PowerMac 6,1.
    – Dave N
    Commented Aug 17, 2022 at 15:11
  • iMac doesn't boot from the newly made clone in a 'toaster' connected by FW 400. :-(
    – Dave N
    Commented Aug 17, 2022 at 15:27

1 Answer 1

1

On another site, a member of a group specializing in vintage Macs asked me to check the partition settings of the SSD in the iMac. They noted that when I had configured the SSD I had from recent habit set it to GUID, which doesn't work on PowerPC Mac startup disks. After changing to Apple Partition Map, which is the required setting for startup disks in PowerPC Macs, and re-cloning, it works like a champ!

So I did everything else ok, from the surgery to cloning, just missed this one setting, which after 20 years was somehow not right in front of my brain, and not in any of the instructions I read.

Also, put the newly purchased RAM back in and it also functions fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .