I've been having issues with universal control being intermittent between a Macbook Pro and 2 iPads. I thought maybe there is an issue with one of my devices, so I purchased a Mac Mini M1 16GB. This worked beautifully so I thought maybe I will try re-installing Mac on my MacBook Pro 13" M1. As soon as I did this, Universal Control is now working on the laptop (it wasn't before), but now it won't work on the Mac Mini M1.

Any ideas what could be causing this or how to fix?

I've tried speaking to Apple, 4 separate people told me they will take ownership of this ticket and help resolve it, scheduled follow up calls 3-4 days later and just never turned up, incredibly frustrating!

  • Can you check under System Preferences -> Display and make sure if Universal Control is enabled? If yes, trying toggling the setting followed by restarting your Mac mini.
    – Nimesh Neema
    Commented Aug 15, 2022 at 0:29
  • it was on throughout, it is re-installing MacOS on the laptop that killed it on the Mac Mini for some strange reason, I followed all troubleshooting steps here: apple.stackexchange.com/questions/444208/…
    – Hackeron
    Commented Aug 15, 2022 at 8:36

1 Answer 1


The solution was to change my iCloud password and making sure "sign out all devices" is ticked. I posted more details on another related but slight different question here: Universal Control Stopped Working (12.5)

UPDATE: This was very short lived, the next day this stopped working after a reboot. I give up.

Not the answer you're looking for? Browse other questions tagged .