1

I have an Linux VM running Openmediavault on a separate machine which has a usb3 external drive plugged in. I use this for file shares and time machine backups. It has worked perfectly for years. However, with Monterey 12.5 on my MBP I've noticed some samba issues with copying to the shares and time machine backups are failing.

If I try to copy a folder to the smb share, I see:

The operation can't be completed because you don't have permission to access some of the items.

On my older macbook running Big Sur, the copies complete successfully as well as the time machine backups. On another MBP running Monterey 12.5, I see the same behavior as my main MBP so it seems as this is some Monterey bug.

Google said to try to create a file at /etc/nsmb.conf on my Monterey MBP with this config:

[default]
protocol_vers_map=6

and rebooting. Same issue. I have tried changing the 6 to a 2 and rebooting, but I see the same issue. If I mount the Linux VM (running Openmediavault) and type smbutil statshares -a This is what is displayed:

SERVER_NAME                   192.168.1.48
                              USER_ID                       501
                              SMB_NEGOTIATE                 SMBV_NEG_SMB2_ENABLED
                              SMB_VERSION                   SMB_2.1
                              SMB_ENCRYPT_ALGORITHMS        AES_128_CCM_ENABLED
                              SMB_ENCRYPT_ALGORITHMS        AES_128_GCM_ENABLED
                              SMB_ENCRYPT_ALGORITHMS        AES_256_CCM_ENABLED
                              SMB_ENCRYPT_ALGORITHMS        AES_256_GCM_ENABLED
                              SMB_CURR_ENCRYPT_ALGORITHM    OFF
                              SMB_SHARE_TYPE                DISK
                              SIGNING_SUPPORTED             TRUE
                              EXTENDED_SECURITY_SUPPORTED   TRUE
                              UNIX_SUPPORT                  TRUE
                              LARGE_FILE_SUPPORTED          TRUE
                              OS_X_SERVER                   TRUE
                              DFS_SUPPORTED                 TRUE
                              FILE_LEASING_SUPPORTED        TRUE
                              MULTI_CREDIT_SUPPORTED        TRUE

The Openmediavault forum said this was a Monterey issue, and not anything with their software. It does seem as if it is, as my old MBP with Big Sur works perfectly with the smb shares.

Have you all seen this behavior with Monterey, and how did you fix it?

3
  • What version of smb is your server and we can guess macOS is only the client here (only mounting shares external to it?) please edit clarifying information into the body of the question if possible. If you link to what exactly you found on Google, we can often help you with a better search/guide as well once we understand the setup
    – bmike
    Aug 13, 2022 at 16:18
  • Thanks @bmike. I added some info. Hopefully this clarifies some things. Thanks for reading.
    – 808mrb
    Aug 15, 2022 at 1:26
  • Nice edits, especially the statshares showing you negotiated 2.1
    – bmike
    Aug 15, 2022 at 2:50

1 Answer 1

0

I found the solution that seems to have fixed this for me on OMV forum.

Apparently, this is a behaviour exhibited when one of Your SMB shares has Time Machine support enabled and You're trying to copy into another one (where it's not enabled).

When you enable TMS support on just one share you end up changing the "vfs objects" configuration of all shares in /etc/samba/smb.conf on OMV6 it changes all shares from:
"vfs objects = "
to
"vfs objects = fruit streams_xattr"

To verify if this is indeed your problem, you could try to temporarily disable all shares' Time Machine support. For me, this resolved the issue (I don't get The operation can't be completed because you don't have permission to access some of the items when trying to paste a folder anymore.)

If you need to have Time Machine support enabled on some shares, you can try this temporary workaround:

way around this is to setup everything the way you want it and then add the following line to the extra options of each non Time Machine share:
"vfs objects = ""
This is kinda horrible because it adds two "vfs objects" line to each non TM shares in the smb.conf but the last one added via the extras takes precedence.

Just remember that if you edit /etc/samba/smb.conf manually, any changes done via OMV UI will overwrite Your custom settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .