0

I previously used an old version of Maxima, but since migrating my old Mac to my new M1 Mac, the binary would not launch.

So I used 'AppCleaner' to remove all support files and binaries for Maxima, and for wxMaxima. I then downloaded the latest version: Maxima-5.41.0-VTK-macOS.dmg. First thing was to run:

xattr -d com.apple.quarantine

.. on the newly downloaded DMG file. I then copied the binary to /Applications and tried to run it. The error message is as in the screenshot, which in English would be 'unable to send Apple events to the Terminal' or something similar. enter image description here

I looked on 'Ask Different' and found this, which advised me to run the applet in /Applications/Maxima.app/Contents/MacOS. But that gave the same result.

For info, this is a Mac Mini running Monterey 12.4.

1
  • Not an answer to your question, but I recently installed wxMaxima from MacPorts on a MacBook Air with Apple Silicon (M2), and that runs without problems.
    – Martin R
    Aug 4 at 11:13

0

You must log in to answer this question.

Browse other questions tagged .