I have some files in WriteNow and WordPerfect format. The WriteNow files go back as far as 1987 and the WordPerfect files are from 1998 - 2001. Some I can read, others I can't open at all. Those I can read lose most of the formatting.

I'm talking basic "RTF-like" formatting for the most part, not super obscure proprietary word processing features à la the Home Depot that is MS Word. There are also some embedded graphics in whatever was the generic standard for Macintosh back then.

Even if a file might be in RTF, that standard has changed significantly over the years and formatting is lost for the most part.

I don't have the original software or a machine to run it on.


for WordPerfect documents, you can also try to use OpenOffice, LibreOffice, NeoOffice (...), libwpd filter (see http://libwpd.sourceforge.net/features.html ) will then be used to convert the document in odt format.

For WriteNow files, the best solution is probably using an emulator. If you have access to a 64 bit Intel Mac with OsX 10.6 ( or 10.7), you can also find on http://sourceforge.net/projects/libmwaw/files/ a precompilated version of a WriteNow filter to odt : mwawOSX.zip ; ie I tried to write a small filter to convert WriteNow files, it works "well enough" on the few WriteNow files that I had found, so maybe it can work also for your files ( or maybe not :-~ ).


If you can find someone in your local Mac users group who has a working copy of DataViz's discontinued MacLink Plus product, you may be able to convert the files to a modern format.

If you have access to a Classic-capable machine (10.4 PPC), you could try the freeware version of FullWrite Pro from this site http://www.encyclomedia.ca/fwp/

  • 1
    I don't believe MacLink Plus will run under Lion. – jaberg Mar 19 '12 at 18:46
  • jaberg, of course you are right. What you really need is a working Mac running Mac OS 8 or Mac OS 9 and the DataViz MacLink product. Good luck. – user9290 Mar 19 '12 at 19:41
  • I have maclink plus deluxe running on Snow Leopard. I can see text but formatting is not there and the graphics are missing – radarbob Mar 20 '12 at 1:29

You don't necessarily need to find old hardware; much of what is described above can be done in an emulator like Basilisk II and, depending on your attitude towards pirating ancient software, you can probably find the old applications online as well (see for example http://www.macintoshgarden.org/apps/word-processing-presentation). I salvaged work in Pagemaker 2 format (circa 1991) with an emulator recently.


NeoOffice seems to be able to open all my old files, WordPerfect and WriteNow!

  • 1
    Maybe you could expand on this answer a bit? Include a link to NeoOffice and some screen shots of some converted files if possible? It's a nice answer now, but with some effort it could be a really excellent answer. – Ian C. Oct 4 '17 at 18:37
  • I used this answer successfully. I used LibreOffice (of which NeoOffice is a fork) to open an old WriteNow! document. It worked. – Jamie Cox Jul 23 '18 at 11:59

I can't address the specific file formats you're dealing with, but I had to do a manual conversion of some older AppleWorks documents. (AppleWorks v. 5 — Pages won't open them.)

This is a last ditch effort, something to try once other methods have failed.

I was able to open them as plain text files in TextEdit by selecting the documents in the finder and using Open With… from the contextual menu. Each document had a noisy header and footer, which I deleted, but the body of the work was present.

Then I read through and removed junk (extraneous) characters and re-formatted the document using Markdown. If there had been more documents, or had they been longer, I would have brought the text file over to BBEdit, and used a series of search/replace to clean up the documents.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .