2

I have a Retina 4K, 21.5-inch, 2019 running MacOS Monterey 12.4 (21F79).

My iMac shipped with Catalina and it worked so smooth and wonderfully. Eventually I upgraded to Big-Sur and used it for nearly a year, but very occasionally it would do minor weird things causing the computer to run slow, or have applications not respond.

Eventually I thought, I need to do a clean install of MacOS, maybe that will fix these bugs.

I did that two weeks ago, but I have realized it was a bad idea. The iMac is doing really weird things now. Now, about half the times I reboot it, or after I wake it up from sleep, it starts crashing. I usually have to trigger it a few minutes later by quickly interacting with two applications. For example, it's usually something like, I'll open my browser and while the app is opening and loading the data, I'll do something else like open another application or finder window, and this can trigger it to go crazy. But once it starts with the spinning loading cursor, it just doesn't seem to fix until I manage to reboot the iMac. What's really annoying is that because it's freezing, it takes about 10-20 minutes to actually reboot. I try and click the Apple symbol in the top left, but it takes two minutes to open etc.; each step taking a painful amount of time. On around three occasions I've had to just hold down the power button on the back of the iMac to force it to finish shutting down. It either shows the blank desktop background or a black screen (with the back-light on), even when I let the computer sit overnight, it doesn't fully power off on these occasions.

Some more details which might help to diagnose what's happening is that it seems to cause problems to Finder, and the mouse and keyboard most often. Finder is usually the application to be 'not responding'. If it isn't at first, it usually is by the time I try to click things to quit the first application that isn't responding.

The mouse can stop working for certain applications but not for others which I find really strange. For example, I might be able to click inside an application to highlight text for example, but it won't register clicks to close the application.

The keyboard often stops working completely. Sometimes, switching it off and on again does resolve this. But interestingly, occasionally I get a window pop-up that says 'Keyboard Assistant' and it asks if I have a USB keyboard connected. I can't remember now what I do or what it says exactly, but I believe I click OK and ignore it because I don't have a USB keyboard connected at the time. So I guess this is coming up because it is detecting something strange with the keyboard, maybe.

When the mouse and keyboard stop working, using a USB mouse and keyboard always works. Just to be clear, when I'm using the iMac normally, a second USB gaming mouse is permanently connected, and I switch to either one as needed, but the Apple keyboard is normally the only keyboard connected.

I'm wondering if the mouse and keyboard are causing it to crash, or whether it crashes and causes the Bluetooth devices to stop working.

Does anyone know what I should do here? I'm tempted to wipe it again and install Catalina which was the only version that actually worked without bugs of some kind, but I don't know how much longer there will be security updates for it. I figured that I should ask here in case there's something I should do instead. Is there some tests I can do to diagnose the problem?

Is this a common thing for an older Macs to run so badly with modern MacOS? I mean, it's really not that old, but I understand that Monterey is designed mainly for Macs with Apple silicon so might that cause it to introduce more bugs to intel Macs? And these aren't just bugs, it's constantly crashing. Also, the iMac has 8GB RAM, is that too low for this OS?

Any information would be greatly appreciated.

UPDATE:

After Tetsujin's comment about memory. I permanently dedicated the right side of my screen to display the memory tab with Activity Monitor. When the computer crashed, I could check exactly which application was not responding, and what the used memory and SWAP was.

The first time I noticed problems was during a file transfer to an external hard drive. It told me an 8GB transfer of a single video file was going to 3 hours (it would usually take 10 minutes or so). Nothing was 'not responding' but I knew something was wrong. I tried to restart and as always, it took about 20 minutes to get the machine rebooted.

The memory readings at this point were:

Memory Used: 4.10GB
Cached Files: 3.87GB
Swap Used: 103 MB

These readings seem OK. The memory pressure graph was in the green.

The next day, I decided to manually force the memory up by opening a load of apps.

I opened both Firefox and Brave browsers and loaded up with multiple YouTube tabs as well as a mix of other websites.

It took a lot for me to get the used memory to go over 6 GB. And it was working fast up to about this point, and the memory pressure graph was still green. With about 30 tabs, and lots of Applications open including both Logic Pro X and Garageband, the readings were at:

Memory Used: 7.13 GB
Cached Files: 863.9 MB
Swap Used: 707.0 MB

The graph now was displaying orange.

I was now pushing a lot of memory into Swap, but I kept going. The computer was running slow, and occasionally not responding for a second but It seemed to be doing OK.

The highest SWAP I got was:

Memory Used: 6.53 GB
Cached Files: 1.37 GB
Swap Used: 2.84 GB 

And at this point, so much memory was in the SWAP that the graph showed green again.

I'm guessing this test isn't really the same, because I wasn't using the apps too much. Maybe if it actually had to read and write a lot of data from/to memory it would have crashed?

Anyway. I kept monitoring it over the next few days, with my typical computer use.

A while later that day, it caused problems immediately after being woken up from sleep which seems to be the most usual time. It took 2 minutes for the lock screen to appear and the keyboard was slow to enter and verify the password.

The readings at this point were:

Memory Used: 5.70 GB
Cached Files: 2.13 GB
Swap Used: 176 MB 

Oddly, despite having less applications open than usual, the used memory was 5.70 GB, which is the highest it went in normal use during these past days. However the memory pressure graph still displayed green. The process 'loginwindow' was not responding after a while which is what seems to cause the biggest problems when it does that. Again I tried to shutdown and it took ages and eventually displayed a message: 'Your computer restarted because of a problem. Press a key or wait a few seconds to continue starting up'. I have seen this message twice now. Often it will just blackscreen and take me back to the login screen.

After the message, it started up. And the readings were:

Memory Used: 4.49 GB
Cached Files: 3.49 GB
Swap Used: 0 bytes 

Another time, the mouse scroll stopped working on the Apple mouse (USB worked fine), but clicking and moving still worked on the Apple mouse which is strange.

As Tetsujin suggested, I did the boot in safe mode for recaching at this point.

I noticed that three video files I downloaded were corrupted. Apparently this can be caused by bad RAM. I did a diagnosis boot by holding the D key at startup but it told me the system was OK.

Just before writing this update, a great example of weirdness happened.

Web pages were loading slowly; Firefox was in an out of consciousness. But, as suggested, provided I wait long enough, it would always start responding again. Eventually, I had to reboot because it wasn't functional.

And the readings were:

Memory Used: 4.31 GB
Cached Files: 3.01 GB
Swap Used: 0 bytes 

Surely 4.31/8.00 GB RAM usage is good and low, and Swap is obviously not being used. I don't understand cached files, is that high?

Typically 'Memory Used' was between 3-5 GB. Only twice did I see it it go over 5.

1 Answer 1

0

At a first guess, I'd say you have swap issues - something is using far too much RAM [easy on just 8GB] & the computer is swapping memory to HD. I know through personal experience those Fusion Drive iMacs have terrible HD performance. This is going to manifest as huge delays in everything you try to do. Actually, if you wait it out, eventually things will work, you just need infinite patience, resisting the temptation to click something else just to see if it will work.

First, from a cold boot, hold the shift key until the login window appears [or the desktop if you have it auto-login]. This will take a long time; you might be best preparing something you can rest on the shift key while you go make tea & a sandwich ;)

Once you've got to the desktop, no apps should load. You'll just have Finder. Leave it like this, but don't let it fall asleep, for maybe 15-30 minutes, as it will rebuild some caches in the back ground. Whilst booted to safe mode, everything will be truly glacially slow, including simple screen re-draw - this is because many optimisations will not be loaded. Have patience with it, even more than usual.

After this, reboot, set it not to reopen windows when logging back in.

See if things are better.
There may be some extra time required to finish rebuilding caches, so again be patient.

You may need to keep an eye on Activity Monitor, with the Memory tab showing, to see what causes this high memory requirement. Browsers can be really bad [especially Chrome; you may need to switch to Safari instead if it persists.]
If you set the View menu to All Processes, then sort high usage to the top, this may help, though browsers don't show all their usage in one 'block' belonging to the browser itself, each open tab has its own usage.
If you see overall memory usage going into orange or red, it's time to quit some high usage apps.

2
  • Hi! Thanks for your reply. I've added an update to my post with some observations from these past days using Activity Monitor. I also did a boot in safe mode like you suggested. For the first couple of days the SWAP was around 100MB typically. Is anything other than zero bad? Since then (perhaps since I booted in safe mode) it now reads 0 bytes, yet it still crashes regularly. What do you think about downloaded files being corrupted? Could this mean it's my RAM causing the problems, or could the apps freezing all the time mean that the apps cause downloading files to be corrupted? Aug 2 at 18:47
  • The slow file copy & slow reboot could indicate drive issues. Make sure your backup is up to date before proceeding. Test your internal with the external disconnected, then test the external.
    – Tetsujin
    Aug 3 at 15:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .