0

I bought a new Macbook Pro with Monterey 12.5 and migrated all data from an 11.4 Big Sur using Migration Assistant. When starting up the new Macbook I could not connect to internet even though I was connected to various wifi connections (which were all in good working order).

I ran wireless diagnostics and received a DNS resolution failure issue.

Things I have tried:

  • Restarting laptop
  • Changing DNS to Google and OpenDNS addresses
  • Renewing DHCP
  • Deleting a bunch of apps which I thought could cause an issue (Cisco webex, Epress VPN)
  • Tried creating another user and logging in with another credentials
  • Ultimately re-installed Mac OS

I also started up in safe mode. And that time the internet worked!

However, when coming back out of safe mode, the issue persists.

What are your thoughts on the actions that I should take?

4
  • remove the Wi-Fi connection from System Preferences>Network>Wi-Fi via the (-) below the list of connections. In the Finder menu bar select Go>Go to Folder and change to /Library/Preferences/SystemConfiguration/. Move com.apple.airport.preferences.plist, com.apple.network.identification.plist or com.apple.network.eapolclient.configuration.plist, com.apple.wifi.message-tracer.plist, NetworkInterfaces.plist preferences.plist to the trash and empty it using Command + Delete. Go back to the Network preferences and add your Wi-Fi connection. Commented Jul 28, 2022 at 13:18
  • Depending on your router it might be additionally necessary to turn off iCloud Private Relay. If the wireless connection periodically drops change the MTU to 1453. Commented Jul 28, 2022 at 13:23
  • Thanks both - update: I tried safe mode again, it worked. I went back into the normal mode and my connection works. Not sure what happened. Is it still worth doing what you suggested @slartibartfast ?
    – Badalyan
    Commented Jul 28, 2022 at 15:06
  • probably not. why bother. enjoy! Commented Jul 28, 2022 at 19:08

0

You must log in to answer this question.

Browse other questions tagged .