0

I upgraded mu and emacs and now mu4e stopped working.

I removed Emacs with:

brew uninstall --force emacs
brew uninstall --force homebrew/cask/emacs

and mu with:

brew uninstall mu

Then I installed emacs again with:

$ brew install homebrew/cask/emacs
Running `brew update --auto-update`...
==> Downloading https://emacsformacosx.com/emacs-builds/Emacs-28.1-4-universal.dmg
==> Downloading from https://emacsformacosx.com/download/emacs-builds/Emacs-28.1-4-universal.dmg
######################################################################## 100.0%
==> Installing Cask emacs
==> Moving App 'Emacs.app' to '/Applications/Emacs.app'
==> Linking Binary 'Emacs' to '/usr/local/bin/emacs'
==> Linking Binary 'ebrowse' to '/usr/local/bin/ebrowse'
==> Linking Binary 'emacsclient' to '/usr/local/bin/emacsclient'
==> Linking Binary 'etags' to '/usr/local/bin/etags'
==> Linking Manpage 'ebrowse.1.gz' to '/usr/local/share/man/man1/ebrowse.1.gz'
==> Linking Manpage 'emacs.1.gz' to '/usr/local/share/man/man1/emacs.1.gz'
==> Linking Manpage 'emacsclient.1.gz' to '/usr/local/share/man/man1/emacsclient.1.gz'
==> Linking Manpage 'etags.1.gz' to '/usr/local/share/man/man1/etags.1.gz'
🍺  emacs was successfully installed!

and mu with:

$ brew install mu
Warning: You are using macOS 10.14.
We (and Apple) do not provide support for this old version.
You will encounter build failures with some formulae.
Please create pull requests instead of asking for help on Homebrew's GitHub,
Twitter or any other official channels. You are responsible for resolving
any issues you experience while you are running this
old version.

==> Downloading https://github.com/djcb/mu/releases/download/v1.8.7/mu-1.8.7.tar.xz
Already downloaded: /Users/mmorin/Library/Caches/Homebrew/downloads/c9448438bd8aad02695c3987230eb7478f831fa4e0ec02ba2abe5f7949a793e5--mu-1.8.7.tar.xz
Warning: A newer Command Line Tools release is available.
Update them from Software Update in System Preferences or run:
  softwareupdate --all --install --force

If that doesn't show you any updates, run:
  sudo rm -rf /Library/Developer/CommandLineTools
  sudo xcode-select --install

Alternatively, manually download them from:
  https://developer.apple.com/download/all/.
You should download the Command Line Tools for Xcode 11.3.1.

Error: An exception occurred within a child process:
  RuntimeError: /usr/local/opt/emacs not present or broken
Please reinstall emacs. Sorry :(

I also upgraded command-line tools with:

sudo rm -rf /Library/Developer/CommandLineTools
sudo xcode-select --install

but I still see that message about an old version of command-line tools.

mu complains that /usr/local/opt/emacs is missing, which it is.

Following a question from a few years ago, I also tried:

EMACS=$(which emacs) brew install mu --HEAD

and I get the same error.

When I launch Emacs, I see:

Warning (initialization): An error occurred while loading ‘...’:

File is missing: Cannot open load file, No such file or directory, mu4e

To ensure normal operation, you should investigate and remove the
cause of the error in your initialization file.  Start Emacs with
the ‘--debug-init’ option to view a complete error backtrace. Disable showing Disable logging

This last error usually happens when /usr/local/share/emacs/site-lisp/mu/mu4e/ is missing, but I checked that it does exist on my system:

$ ls /usr/local/share/emacs/site-lisp/mu/mu4e/
Makefile.am TODO        fdl.texi    mu4e-about.org  mu4e-meta.el.in mu4e.texi

The last thing I could try, but which is troublesome for me at the moment, is to reinstall and upgrade the OS because Brew and Apple no longer support 10.14.

Before reinstalling, is there anything else I could try to make mu and mu4e work on Emacs?

update

I reinstalled Emacs and it is now at the latest version:

$ brew upgrade --cask emacs
Warning: Not upgrading emacs, the latest version is already installed

When I install mu, I see that it installs emacs again:

==> Installing mu dependency: emacs
...
==> ./configure --enable-locallisppath=/usr/local/share/emacs/site-lisp --infodir=/usr/local/Cellar/emacs/28.1/share/info/emacs --prefix=/usr/local/Cellar/emacs/28.1 --with-gnutls --without-x 
==> make                                
==> make install
==> emacs cask is installed, skipping link.
Error: Failed to install service files
🍺  /usr/local/Cellar/emacs/28.1: 4,093 files, 110.1MB, built in 5 minutes 35 seconds

So maybe that is the issue: how can I install a single version of emacs for the GUI and the command-line?

8
  • 1
    The GUI emacs also runs on the command line pass -nw as an argument toi make it stay in the terminal
    – mmmmmm
    Jul 27, 2022 at 22:35
  • 1
    Also note that Homebrew does not support macOS 10.14 so you might be better off using a package manager that does e.g. Macports
    – mmmmmm
    Jul 28, 2022 at 7:39
  • @mmmmmm I ran emacs -nw and then on another window brew install mu and go the same error.
    – emonigma
    Jul 28, 2022 at 9:22
  • 1
    Macports doesn't install into /usr/local by default so it is unlikely that that path is correct use port contents mu to see where the files that mu installs are
    – mmmmmm
    Jul 28, 2022 at 9:27
  • 1
    I think looking at port info and ports.macports.org/port/mu/details you need to install the emacs variant i.e. sudo port install mu +emacs
    – mmmmmm
    Jul 28, 2022 at 9:59

1 Answer 1

1

Summarizing the discussion in the comments:

Homebrew does not support macOS 10.14 so you might be better off using a package manager that does e.g. Macports.

Download the MacPorts installer from the official page and run it.

Then (from looking at port info and ports.macports.org/port/mu/details) install the emacs variant of mu:

sudo port install mu +emacs

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .