I'm aware of command + ctrl + space to bring up the emoji selection tool.

However, I use thumbs up quite a bit, and it would be convenient to assign it to a keyboard shortcut to save going through the menu every time.

Is it possible to assign various emojis to key combinations (i.e. keyboard shortcuts)?

1 Answer 1


You can do this in System Prefs > Keyboard > Text
It wouldn't be wise to make these single letter shortcuts, nor real words.

Here are some examples.

enter image description here

I've only added the full stop [period] to the beginning to sort them all together, though it is valid as a trigger at the front, but not at the end.
The trigger itself needs a space or punctuation afterwards to do the 'swap' [why a full stop at the end of the trigger itself is awkward]

So, like this .ks[space] generates 💋 etc.

  • Thanks a lot for the quick (and helpful) answer. I just tried adding tu (for thumbs up) and it creates a 👍 instead (which is great). This is definitely useful. But I was hoping to make it a keyboard shortcut (e.g. command + t + u). Do you know if it's possible?
    – stevec
    Jul 25, 2022 at 9:37
  • 1
    Double letter shortcuts can't be done natively. Simple Cmd + one letter tend to already be used somewhere. So.. sure, this is technically possible using Automator & Applescript structure saved as a Service, it would be a nuisance to use; you'd need 'complex' triggers to not fall over other commands. I'd consider it not worth the effort, tbh.
    – Tetsujin
    Jul 25, 2022 at 9:48
  • 2
    If you wanted to play around with Ukelele you could swap in some emojis on the lesser-used glyphs, I suppose. For instance, swapping out Ê, usually on Opt/Shift/T, as a 'thumb'.
    – Tetsujin
    Jul 25, 2022 at 9:51
  • One additional thing I noticed about this is is seems to sync across MacBook and phone. Quite handy!
    – stevec
    Nov 9, 2022 at 18:50
  • @stevec - Yup, indeed. The sometimes irritating thing is every so often the phone syncs back the original defaults… from out of the blue, & you have to delete them again. [Haven't seen this happen in a while, they may have fixed it by now] 👍
    – Tetsujin
    Nov 9, 2022 at 18:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .