Universal Control has always been extremely glitchy for me, sometimes it works great a week, other times it flat out refuses to show up at all.

I recently managed to get it working by factory resetting the MacBook and re-installing 12.4 but it broke again when updating to 12.5. I tried to factory reset the MacBook and iPad (again), this worked temporarily for a few hours and stopped working again.

I have spent about 15 hours on the phone with Apple on 10+ calls and finally they agreed for a single person to take ownership of the case, but they will not pass it to engineers yet (argh!). Their suggestion has always been to re-install the OS so far (which I have done twice this week!) after the same common troubleshooting steps:

  • Turn it off and back on, create a new user, safe mode, disable screen time.
  • Signing out/back in of Apple ID on all devices, ensure no VPNs, security software, etc, etc, etc - all of which I followed countless times at this point

My setup is:

  • MacBook Pro 13" M1 2020 - v12.5
  • iPad Air 4 - v15.6
  • I also have an iPad Mini 6 (v15.6) but I am keeping it switched off to isolate the issue.
  • Tried on multiple wifi networks, as well as a Virgin Media Hub (latest with wifi6) isolated to just my MacBook and iPad (I'm usually using a Ubiquiti Wifi6 LR AP, testing 1m away from the dish).

After many many hours of experimenting, I found a consistent reproducible case and captured some logs. These are the steps to reproduce:

  1. Turn off "Cursor and Keyboard" on iPad

  2. Kill UniversalControl process on the Mac and delete the settings by running:

    cd ~/Library; killall -9 UniversalControl; rm ./Preferences/ByHost/com.apple.universalcontrol* ./SyncedPreferences/com.apple.kvs/ChangeTokens/EndToEndEncryption/UniversalControl/com.apple.universalcontrol; killall -9 UniversalControl

  3. Toggle universal control off and back on on Mac

  4. Turn on "Cursor and Keyboard" on iPad and reboot the iPad

This will make Universal Control work. However, putting the iPad to sleep and then waking it causes Universal Control to disconnect permanently. It will not show up again until the above steps are followed again.

I recorded a video of this here: https://www.youtube.com/watch?v=3fNYcsd_2h0

I also recoded a longer video of the entire setup: https://youtu.be/qZ4VbEe8nHM

I also captured the iPad logs in Console.app:

  1. Successfully connecting the iPad: https://gist.github.com/rgaufman/294b21fcf9b7f86bd3452b6ccdff4a3d

  2. Putting iPad to sleep and waking it (causes a permanent disconnect): https://gist.github.com/rgaufman/4edd52af92ca8be2af5f2af58b1cce6c

I also captured logs on the Mac on the isolated network:

  1. Successfully connecting iPad Air4: https://gist.github.com/rgaufman/7ff744d6d4b412544ecb4da660c4f7d9

  2. Air4 Disconnecting immediately when I switch on the iPad Mini 6: https://gist.github.com/rgaufman/b13890f8277266ac7636a2ceb9a7cea2

There is a different but related issue here with more details: Universal Control Stopped Working (12.5)

1 Answer 1


The solution was to change my iCloud password and making sure "sign out all devices" is ticked. I posted more details on another related but slight different question here: Universal Control Stopped Working (12.5)

EDIT: 2023-06 Unfortunately it stopped working again, I do not know why, I give up...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .