Every update Universal Control stops working. There is another thread here: Universal Control Stopped Working (12.4)

Trying the usual steps:

  1. Creating another admin user on mac
  2. Booting in safe mode
  3. Turning of share cursor and keyboard on the ipad / reboot / turn back on
  4. Factory resetting the Macbook Pro 13" M1, iPad Air4 and iPad Mini 6 - it fixes it for a few hours and then it breaks again.

Nothing works.

I called Apple and they said you need to re-install the OS again (I just re-installed a week ago!!).

It seems every OS update universal control stops working.

Is there any solution to this other than to format and reinstall?


I managed to get 1 iPad Air4 to connect and captured these logs: https://gist.github.com/rgaufman/7ff744d6d4b412544ecb4da660c4f7d9

When I switch on the iPad Mini 5, the Air4 disconnects immediately and then struggles to reconnect. This is what I see in the logs: https://gist.github.com/rgaufman/b13890f8277266ac7636a2ceb9a7cea2


I had 4 separate people from Apple promise to take ownership of this ticket and scheduled calls that they did not turn up to. It has been a horribly disappointing experience.

I purchased a Mac Mini M1 16GB, did a fresh install and Handoff was working on it all day (got it today). I then thought ah, I will try to re-install Mac (4th time) on the Macbook Pro, this immediately killed handoff on the Mac Mini but now works on the Macbook Pro (I am guessing very temporarily!).

Still looking for a solution for this :(

  • I spent a few more hours on the phone with apple to no avail :( - they said they have a few customers with this issue.
    – Hackeron
    Commented Jul 23, 2022 at 19:28
  • I called Apple, and they didn't even know the feature exists.
    – 2540625
    Commented Dec 1, 2022 at 21:07

3 Answers 3


After literally months of trying to find a solution, what I did was change my iCloud account password and ticked "sign out all devices".

Note it is not enough to just change the password (which I've tried) and it is not enough to manually sign out of iCloud on each device (which I've tried multiple times). You must tick "sign out all devices" which does something different.

This is a pain because it resets all your app specific passwords, stops things like SMS forwarding, even after re-signing in, things like imessage don't work across devices until you sign in messages manually on your iPhone. But it's worth it if you want Universal Control to work.

After doing this song and dance, it still wasn't working, so the final step was to turn all devices off and back on. After booting, I can now move my mouse between a Macbook Pro 13" M1, a Mac Mini M1 and an iPad Air 3, excellent!

As a side note, I had duplicate devices listed for features like Wifi Calling, "Calls on other devices" and "Text Message Forwarding" - it didn't impact the functionality but those duplicates are gone too.

I hope this lasts as this is game changing functionality!

UPDATE: This was very short lived, the next day this stopped working after a reboot. I give up.

  • Do you by chance have Docker Desktop, FortiClient or Microsoft Defender running on your machine? I think it's one of these 3 possibly altering my network settings. I closed Docker and immediately saw my other laptop appear in Universal Control, and then I was able to resume Docker. Just not 100% sure yet.
    – geekinit
    Commented Oct 4, 2022 at 16:59
  • 1
    Nope, none of those.
    – Hackeron
    Commented Oct 8, 2022 at 3:25
  • Mine was working great for 5 days and this morning my laptop asked me to re-enter my iCloud password to enable a service. Since then it's been losing the connection. From terminal the killall UniveralControl command brings it back, but then it stops again after a period of time.
    – geekinit
    Commented Oct 10, 2022 at 16:18

After many months of struggling with this, this has been working stable after updating to Ventura 13.0, woo!

EDIT: 2023-06 Unfortunately it stopped working again, I do not know why, I give up...

  • is it still working? Commented Dec 22, 2022 at 22:46
  • Yes thankfully.
    – Hackeron
    Commented Dec 23, 2022 at 10:59
  • 1
    Mine has been working fine so far. Commented Dec 29, 2022 at 22:54
  • It stopped working since then, I have not been able to get it to work, I give up...
    – Hackeron
    Commented May 31, 2023 at 17:28

I have Ventura 13.2 I was trying to do this in many ways, until I checked some options, and it worked!!!

  • Sign in all the computers with you Apple ID
  • Check the options for Universal Control as in the guide: https://support.apple.com/en-us/HT212757 Steps related with the Handoff and Universal Control
  • Check the in General that your main laptop - the one who has the keyboard and mouse associates have the proper sharing options (notice that in general you could see AirDrop and Handoff check those options too):

enter image description here

then go to Sharing. Note: it's important to have all the 3 or 2 laptops/devices sharing bluetooth in case you have a external bluetooth keyboard (please check the bluetooth check as follow)

enter image description here

then check all of these options. I was able to configure this with the next steps:

enter image description here

I was able to link the keyboard and mouse to navigate between 3 MacBook Pro computers

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .