49

In macOS Monterey it seems that menu bar entries can only occupy the space from the right corner to the notch in the middle. If you add more menu bar entries they just get hidden and you don't have any chance to see/interact with them.

Considering that the spacing has been increased (Can the spacing of menu bar apps be modified in Big Sur?) this is really a big problem. Menubar-living tools like iStatMenu are hardly usable.

So my question boils down to: How to force macOS to really show all menu bar icons? (be it by overflowing to the left side of the notch, decreasing spacing between the icons, 2-line menu bar, whatever)

1

7 Answers 7

22

Dealing with the same issue on my MacBook. The only solution I know of is using Bartender to manage the items. It has a feature called Bartender Bar that allows the icons to move to a separate space below the menu bar where they won't be cut off by the notch. It also allows you to decrease the spacing between icons allowing for more icons onscreen before they hit the notch. Unfortunately, it's a paid software with a one-time $16 fee (though it does offer a free 4-week trial). Free alternatives to hide menu bar icons (like Dozer and HiddenBar) can't prevent icons from hiding behind the notch when expanded, or change the icon spacing.

2
22

On macOS 13 Ventura, you can change the resolution from system settings and that will move the menu bar below the notch.

  1. Go to System Settings -> Displays
  2. Right click (or control-click) on the resolution area and select Show List enter image description here
  3. Then tick the Show all resolutions and select 1512x945 (just below the default one) or any other "non-standard" resolution enter image description here
0
11

There is Say No to Notch available on the App Store.

Works as described on my MBA 2022 (moving the menubar down one row).

1
  • Thanks for an answer which also includes a screenshot to understand what this notch thing is. :)
    – Nemo
    Commented Mar 11 at 6:45
9

Apple lets you scale the menu bar for this use case.

This is a per-app preference, so you need to quit the app and then get information on each app in Finder. Enable Scale to fit below built-in camera and Bob’s your uncle.

2
  • That setting didn't work for me on MBP 16" Sonoma for Docker Desktop and other apps. The icon remained hidden even after restarting. The linked docs refer to unhiding an "app's settings", and I guess the app icon is not part of that.
    – tony19
    Commented Jan 12 at 21:09
  • Oh no @tony19 I wonder if being in full screen mode or not matters for those apps. Have you investigated these global settings?
    – bmike
    Commented Jan 24 at 21:33
9

After some time searching, finally I found what I think is the best solution:

The answer at Can the spacing of menu bar apps be modified in macOS Big Sur and later? you can see:

defaults -currentHost write -globalDomain NSStatusItemSpacing -int #

(Replace # with the number of your choice, with lower numbers being less space between icons, and enter the command in Terminal.) For me setting it to 8 is enough, but you can still go with less. Users in the linked thread recommended anywhere from 6 down all the way to 0. It requires logging out and in again!

1
  • Thank you for this! The terminal doesn't scare me, but I'm totally baffled that I'm forced to do this to be able to use menu bar only apps.
    – Moritz
    Commented 2 days ago
5

It would seem that there is a free app on the app store iBar-Menubar icon control tool that hides icons in the menu-bar and will create a drop-down level that. Full disclosure is that I have not tried it.

(Personally, I use the free app Hidden Bar to manage my menu-icons, but as @nitsujri pointed out in my deleted comment - given enough icons some will still be hidden behind the notch when things are expanded. Looking at the github issues, there is a workaround by changing your monitor's resolution by having preferences list all possible resolutions or with a tool like RDM, but that is a long way to go.)

0
0

Thank you @froblesmartin for providing a simple solution to this baffling problem. I wrote a little zsh program so I won't forget how to do this once my menu bar overflows again. Add this to the .zshrc file in your home directory. For instance by running nano ~/.zshrc in your terminal.

adjustMenuItemSpacing() {
  if [ $# -lt 1 ]
  then
    echo "Usage: $funcstack[1] <spacing>"
    return
  fi
  defaults -currentHost write -globalDomain NSStatusItemSpacing -int "$1"
}

Then just call this function from your terminal and log out and back in again.

adjustMenuItemSpacing 8
New contributor
Moritz is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .