-1

I'm developing a desktop app, so it's unsigned. When launched first time, it fails with access denied. I used to be able to click Open Anyway in the Security Preferences, but now that button is gone. How to allow unsigned apps to run on Monterey?

1
  • 2
    As far as I'm aware, same as ever - right click > open
    – Tetsujin
    Jul 19 at 17:44

2 Answers 2

1

I think:

Go to the executable, right-click, and then choose Open.

Open Anyway and fiddling with the settings has been gone for a while now.

0

I fixed this by removing the quarantine attribute on the executable:

xattr -d com.apple.quarantine ~/myapp

Right-click, Open wasn't an option for me, because I'm running the command from Terminal (via make).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .