I use google contacts on my iPhone and previous mac, but recently switched to a new mac.

After linking the iCloud account to messages on mac, and adding google contacts to the internet accounts, I managed to get it to show the message history, but it's still not showing the contact names.

Closing and opening, updating mac, and restarting the system did not help.

1 Answer 1


The reason I'm leaving this Q&A here, is because the solution was just about the least intuitive and poor product design as I've ever seen.

Following this macrumors comment, what fixed it was adding notes to the google account in System Preferences -> Internet Accounts, then opening a new folder under the google notes.

Go figure...

  • Thank you! This was not the fix for me, but reminded me that I decided to store my contacts in Google. Which I had long since forgotten. Simply adding my Google account to the Mac fixed my phone numbers :) Jun 19 at 7:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .