My MacBook Pro 13" M1 crashed last night, I think because I switched off my external USB-C monitor. I logged in as normal but since then I am not able to open .dmg files.

When I try to open using DiskImageMounter.app, nothing at all happens, no errors, nothing.

When I try to open from the terminal, it just hangs for a while then says operation timed out:

$ hdiutil attach GoogleDrive.dmg
hdiutil: attach failed - Operation timed out

If I try to ctrl+c while it's trying to mount, I see this:

$ hdiutil attach DropboxInstaller.dmg # tried with different dmgs
^Ccanceling...^[[A2022-07-19 13:59:29.626 hdiutil[1971:21611] -[DIHelperProxy(Thread) waitForHelperDone] timed out waiting for helper registration

Strangely, it does show in diskutil:

$ diskutil list

/dev/disk4 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     Apple_partition_scheme                        +334.0 MB   disk4
   1:        Apple_partition_map                         32.3 KB    disk4s1
   2:                  Apple_HFS Install Google Drive    334.0 MB   disk4s2
                    (free space)                         291.3 GB   -

However, trying to eject it, it also just hangs until saying timed out.

$ diskutil eject /dev/disk4
Volume timed out while waiting to eject

What I tried so far:

  1. Reboot several times
  2. Create another admin account - didn't help, same issue.
  3. Boot in safe mode, then it just says resource not available, not sure you can open dmg files in safe mode!
  4. Did "first aid" of the Mac drive in disk utility (no errors found)
  5. Tried different dmg files, including ones that worked yesterday, same result.

I just did a clean install of my MacOS a few days ago, so there's not much third party apps except things like Slack, Chrome.

Any ideas?

1 Answer 1


I fixed it! - I recently ran a command to stop receiving annoying messages about umounted drives:

sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.DiskArbitration.diskarbitrationd.plist DADisableEjectNotification -bool YES && sudo pkill diskarbitrationd

This seems to have broken DMGs, I fixed it by doing:

sudo mv /Library/Preferences/SystemConfiguration/com.apple.DiskArbitration.diskarbitrationd.plist /Library/Preferences/SystemConfiguration/com.apple.DiskArbitration.diskarbitrationd.plist-backup
  • 5
    Sounds like "DADisableEjectNotification" isn't just about notifying you, the user, about disk ejection.
    – Mark
    Jul 19, 2022 at 22:01
  • 2
    The moral of this story seems to be: don't muck around with system components unless you know all the consequences :-) There are a few vaguely-useful tweaks that they didn't choose to expose in the UI; but there are also lots of ways to screw up parts of your system… — Glad you're sorted, anyway, and thanks for sharing your (hard-won) lesson!
    – gidds
    Jul 19, 2022 at 22:34
  • This was actually posted by Linus tech tips recently with hundreds of thousands of likes on the video, I am hoping when there is a flood of people with this problem they find this on google :) was tearing my hair out!
    – Hackeron
    Jul 20, 2022 at 20:28
  • 2
    Just wanted to say thanks. Did the same thing and was wondering it didnt work. Serves me right for copy/pasting commands from the internet. Sep 23, 2022 at 7:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .