1

When I type certain keys around the middle of the keyboard, especially around the keys t, g, h (regardless of modifier key), my Input Source sometimes jumps from my custom-made source (using Ukelele) to US English (my default).

This occurs with any hardware: the build-in Mac keyboard or an external keyboard.

Keyboard Preferences have nothing related to this, just the default input-source switcher (globe).

(Mac M1, OSx 12.4.)

1 Answer 1

1

The solution was to remove ⌥-Space (under System Preferences -> Keyboard -> Shortcuts-> "Select the next input source" ) and revert to the default.

(Apparently Mac reserves it for breaking-space. We have a bug here, as as OSX does not prevent using it or even warn you, just messes things up irregularly.)

(Answer helpfully provided by user dialabrain on the Apple forum.)

8
  • Normally option space is used to create non breaking space characters. The default Input Switching shortcut should be control space. Siri's default is hold command space. Your problem is definitely odd, I've made tons of Ukelele keyboards and never seen that happen. Jul 22, 2022 at 9:49
  • "create... space characters." Thank you. I tried it now and indeed it does that, so I I am editing my text
    – Joshua Fox
    Jul 22, 2022 at 11:20
  • "Switching shortcut should be control space. " Right. Ctl-Space was and is my "Select the previous input source" shortcut. The problematic one was "Select the previous input source" where setting it to Option-space is what caused the bug.
    – Joshua Fox
    Jul 22, 2022 at 11:21
  • "Ukelele keyboards". I think now that this is not the cause. The custom keyboard was made with Ukekele. but the fix was inside the System Preferences so I think the bug is there.
    – Joshua Fox
    Jul 22, 2022 at 11:36
  • Yes, but I gather this bug also never appeared with your US keyboard active? Jul 22, 2022 at 13:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .