0

I'm helping a friend who is trying to get Windows 10 running on his Monterey MacOS within VirtualBox.

We were fine during the first attempt, when linking the ISO file and starting the VM. The Windows installer kicked in. Unfortunately we weren't prepared with a working "Windows Key" and had to abort.

After a working key was found, we tried to run the installation again, but VirtualBox, Settings -> Storage was showing a VERR_ACCESS_DENIED error on the ISO file.

We tried deleting the new Windows VM and starting over by creating a new Windows 10 VM, but attempts to connect to the ISO file produced the same error.

I'm wondering what could be the problem.

In researching, I've seen the following possible causes mentioned:

  1. ISO file corruption. (We are downloading the ISO and will try again.) Is it possible the ISO file got corrupted or was disabled when the installation was aborted?

  2. Lack of ADMIN status. The user is clearly marked Admin and the ISO is on a file on his desktop, and shows read/write privileges.

  3. Two versions of VirtualBox running, with one interfering with the other. He did have two running at one point, but we shut them down, opened one, and the error state persists.

  4. Interference by SIP? We were allowed to access the ISO earlier. It doesn't seem to me that SIP would first allow and then disallow access to a file. But I'm not a MacOS user and am not familiar with SIP or how to troubleshoot issues that might or might not involve it. It's easy to ascribe problems to the things that are the most "mysterious".

Any thoughts or suggestions?

1 Answer 1

1

The newly downloaded ISO worked fine. Windows now installed. So it was probably a file corruption issue in this case.

2
  • Point for the future... why wouldn't you just go back and put the key in after the install was completed? Jul 17, 2022 at 3:25
  • On the first attempt, we didn't know we'd need a key, and getting it was going to take several bureaucratic steps of unknown duration, so we closed out, assuming we could redo the process. When we came back to try again, VirtualBox would not allow a connection to the ISO file and we weren't able to restart the installation process. Jul 17, 2022 at 17:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .