2

I want to press "Don't Allow" but it has become a no-op, doesn't act. I don't want to press OK. This does not show up in the Force Quit applications option. I opened VS code in the Desktop directory by mistake and it started to ask me for permissions. I also quit (command+Q) VS Code.

How can I move ahead without giving VSCode permissions to read my Documents or any folder?

Update 1

I tried to force quit the Finder, relaunch it, and it did not work. enter image description here

2
  • Perhaps it is finder asking for permissions (on behalf of vscode)? What happens if you force quit / relaunch finder? Commented Jul 13, 2022 at 18:51
  • Is there a reason for not giving VSC access to your Documents folder? Wouldn't you have to keep all of your code outside of the Documents folder in any case, in an 'unprotected' folder?
    – benwiggy
    Commented Aug 13, 2022 at 15:36

1 Answer 1

1

While it would be relatively easy to just give the permisssion and then remove it System Preferences > Security and Privacy > Privacy > ... I think it's Disk Access?

Since it's not in the Force Quit options you could try doing it from the terminal getting the process is with top -u maybe and then kill ####

You could try logging out of your user account [Apple Menu > Log Out].

You could also just go nuclear and hold your power button for 10 seconds to force your computer off and then turn it back on at which point VSC if it's not auto launching will no longer be an issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .