4

I have been having an issue lately (I have never had this issue before). When an app gives me a dialog box (such as an applescript error, a permission dialog, or an unexpected quit), I will not be able to answer it. I can click the buttons, but nothing happens. The dialog will stay (I just drag it into the corner if it doesn't need any action), and the action the button does will not execute. This becomes a real pain because, many times, there is an app asking for permission, and I have to log out, log in, and then ask for that permission again to get it to click. It will click for a few hours after log out & log in, but then it freezes up again. I am running Monterey 12.4. This only started after I used migration assistant to migrate from an Intel iMac to an M1 pro Macbook. This does NOT occur with dialog boxes created by or within apps, but only dialogs created by MACOS

These are the types of dialog boxes I am talking about: enter image description here enter image description here enter image description here

However, dialog boxes like this (not draggable, and stuck inside the app's window, not a separate window) never freeze: enter image description here

Edit: this is not related to any particular app. My apps all work fine. It is an issue with just the dialogs, and I am picking on UTM because it is easy to make UTM throw dialogs. But, for example, yesterday, I was trying to set up a VPN. To let the app add a VPN config, a macos networking dialog popped up. I had to log out & log in, then re-add the VPN for me to be able to click the dialog.

2

4 Answers 4

7

It seems that this very specific issue (ineffective mouse clicks in file picker dialogs and in System Preferences) is surprisingly common on Big Sur and Monterey. A couple of workarounds that seem to help a bit in some circumstances:

  • file dialog: resize the dialog
  • System Preferences: minimize and then un-minmize it

The only way that I have found to immediately resolve the problem is (on Terminal):

killall Finder
killall Dock

A million thanks to (apparently) the same person who posted this in both Apple Community forums and on Reddit, as that's the only place I seen it, after tons of web searching:

jondavidschober on Apple Community and Littlejd97 on r/MacOS

3
  • 1
    I will accept the answer if it works once I can replicate the problem (probably tomorrow). Thanks! Jul 7, 2022 at 2:04
  • 1
    This works for me! This issue has been bugging me for months now since the transition to apple silicon, and the only solution was to restart the whole system! Thank you @Danarman, you save my life. Oct 15, 2022 at 16:35
  • 1
    This fixed the issue for me. The key was killing the Dock.
    – maulik13
    Oct 17, 2022 at 10:29
0

I got the same macbook again on a deal & returned the old macbook. In the migration, the issue seems to have gone away. I migrated via time machine backup.

So it seems, to permanently fix this issue, you can try reinstalling monterey. Or, if that fails, factory reset monterey & restore from a time machine backup.

0

Here's my solution, hopefully can help and giving some directions or hints to everyone still suffering by this problem

Mine is 2018 Intel i7 CPU Macbook Pro

I tried the method from anonymous , Erase All Content and Settings by Factory Reset Monterey , spent around 5 hours to reinstall OS and backup recovery by time machine.

At first, It worked! each applications security prompt or pop up selection windows mouse click are finally responding!!!

after that, I restored all my mouse click and keyboard key mapping settings, and it happened again!

The security prompt window just hanged on the screen, there's nothing responding rather you click allow or deny, but the "?" still functioning...that's so confused

Then I tried the second time of Factory Reset Monterey!

But this time, when everything back to normal, I isolated all the key mapping related application (BetterTouchTool,KeyCastr,Karabiner-Elements) , and activate them and each single functions one by one.

Finally, i found that is "KeyCastr" (display mouse click) causing this issue to me

KeyCastr

3
  • 1
    The screenshot in your answer does not seem to be part of any setting in System Preferences in macOS. Can you pls describe how you got there in more detail?
    – Alper
    Oct 4, 2022 at 16:22
  • @Alper Thank you to pointing out this, This is a Preferences Setting in "KeyCastr"
    – VxxxxC
    Oct 7, 2022 at 12:16
  • I am glad you have been able to resolve your problem but the OP does not say anything about a KeyCastr app. It would be more appropriate if you asked a new question and answered it yourself if you thought your particular experience was worth sharing. See this help page for details on answering your own question.
    – Alper
    Oct 8, 2022 at 7:07
0

I too was having this issue, and it was VxxxxC's answer that led to the solution for me. I use a pointer utility, KeyMou, (from Many Tricks) to highlight the pointer to improve visibility. Turning KeyMou off resolved the issue.

Update: In further investigation, along with the support staff at Many Tricks, it seems that it is a combination of utilities that is causing my issue. In my case if both KeyMou and PopClip are enabled, the issue presents. If either (or both) are disabled, the issue is resolved.

So while the OP doesn't say anything about using such a utility I doubt it is a coincidence that the issue appears when such a utility is in use and disappears when it is not.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .