8

I have followed the instructions here to turn on "Find My Mac", but it doesn't work. I have a Macbook Pro 14 inch 2021, with MacOS 12.4 Moneterey installed. I alread had location services turned on, and then specifically enabled it for "Find My".

Now, when I go into Apple ID -> iCloud, and try to turn on "Find My Mac", I get a popup asking if I want to allow find my mac, and then for a second it says "Settin up..." ... and then nothing. See this GIF.

gif of enabling Find my mac failing

It looks like someone else has had this exact problem, so I tried the various things in that post. Namely:

  • I rebooted and tried again
  • I booted in Safe Mode and tried, but got the same behavior
  • I deleted various *.plist files, rebooted, and tried again

All without success. I should note that I also have looked on my other devices and they definitely can't see this Mac on the "Find My" app. So this is a real failure and not just a UI quirk.

(Aside: Is there a command line command or tool to enable these settings? I ask because, completely unrelated to this issue and on my work computer, I was able to fix an issue where I couldn't enable screen sharing with Google Meets by running a command line tool.... but that tool was only for Accessibility options.)

Anyway, I know this is a long shot but hopefully someone is out there who eventually sees this and can answer. I'm going to try to call Apple Support tomorrow and try my luck with them. If I find a solution I'll be back to enlighten y'all.

0

7 Answers 7

10

OK! I got it solved. To summarize the things I tried:

  • Reboot
  • Reboot into safe mode
  • Sign out and sign back in to your Apple ID in System Preferences

That last one is what did the trick for me. I hope this help someone avoid hours of troubleshooting and time on the phone with Apple Support.

4
  • Done that, does not work for me
    – EsseTi
    Commented Nov 18, 2022 at 10:02
  • It worked for me. Maybe I jumped the gun trying to set up Find My before my apple account got fully integrated into all the Mac features. I signed out, then signed back in again and waited for it to fully set itself up. It actually asked me if I wanted to set up Find My automatically and it worked from there
    – vullnetyy
    Commented Nov 22, 2022 at 23:03
  • 1
    Consider marking your answer as accepted if it answers your problem as you said. It avoids it being bumped by Community bot as unsolved.
    – Thinkr
    Commented Apr 11, 2023 at 17:05
  • This worked for me. I migrated to this mac from another mac using time machine few days ago, which was probably somehow connected with the issue. I even didn't need to reboot to safe mode, just signing out and in again did the trick. Commented Oct 12, 2023 at 11:06
1

I had to enable "Home" in System Settings > Privacy & Security > Location Services. Then I could enable Find My.

M1 Ventura 13.0.1

1

I had the same problem. I could fix it as follows: under Privacy & Security -> Location Services -> System Services, I toggled "Find My" off and then on again. When I returned to Apple ID -> iCloud -> Find My Mac, I could turn it on.

0

The initial problem occurred because I had to sign out and sign back in to iCloud, so I didn't want to go through that again.

"I had to enable "Home [Kit]" in System Settings > Privacy & Security > Location Services. Then I could enable Find My." worked for me.

1
  • 2
    How is this different than the answers already provided? It looks to be the exact same solution.
    – fsb
    Commented Dec 15, 2022 at 13:58
0

I solved finally dropping my other Apple ID account that had also bonded to my Mac.

I then logged in again with my Apple ID in my Mac, worked for me!

0

Had the same problem. When someone mentioned Home Kit, it made me think, because I had Home Kit enabled for iCloud but not location services. Enabled Home Kit location services and then it let me turn on FindMy, which is a relief because even though it said it was off, I was still getting notifications that my MacBook had been left behind at home, even though a) FindMy was supposedly off, and b) my home location notifications are off.

0

The above did not work for me.

This did.

  • Create a new admin account and associate it with your Apple ID
  • Go to settings and turn on "Find my Mac"

I then logged out and logged back in as my normal user. It was enabled, and the device now shows up on "Find my" on my phone.

1
  • 1
    Which answer is "the above"? One of them, or all of them? Could you be a bit more specific? Also, which version of macOS are you running? Commented May 14 at 13:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .