I have a problem with my external HDD from Seagate. It was working fine and I was transferring files from it to another external SSD on my MacBook Air (running macOS Monterey). However, the battery on my Mac was low and it turned off midway. After reconnecting, the trouble started. One partition which is used for time machine is not mounting anymore, though it can be seen in diskutil list and Disk Utility. The other two partitions are mounting and I can see the files but they cannot be unmounted. The disk is also not ejecting and I have to just disconnect the usb cable every time. I have tested the HDD with another Mac but the issues remain.

Running diskutil list gives:

Apple$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI ⁨EFI⁩                     209.7 MB   disk0s1
   2:                 Apple_APFS ⁨Container disk1⁩         121.1 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +121.1 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume ⁨Macintosh HD - Data⁩     85.2 GB    disk1s1
   2:                APFS Volume ⁨Preboot⁩                 591.9 MB   disk1s2
   3:                APFS Volume ⁨Recovery⁩                1.6 GB     disk1s3
   4:                APFS Volume ⁨VM⁩                      1.1 GB     disk1s4
   5:                APFS Volume ⁨Macintosh HD⁩            15.2 GB    disk1s5
   6:              APFS Snapshot ⁨com.apple.os.update-...⁩ 15.2 GB    disk1s5s1

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk2
   1:                        EFI ⁨EFI⁩                     209.7 MB   disk2s1
   2:                  Apple_HFS ⁨time_mach2⁩              203.0 GB   disk2s2
   3:                  Apple_HFS ⁨what_toDo⁩               203.1 GB   disk2s3
   4:                  Apple_HFS ⁨things_kept⁩             593.5 GB   disk2s4

I have tried out all the suggestions given in the post External drive does not mount after plug off without eject but to no avail. Results of mountDisk and mount with or without readOnly for the different partitions are:

...Apple$ diskutil mountDisk /dev/disk2
One or more volume(s) failed to mount
...Apple$ diskutil mount /dev/disk2s2
Volume on disk2s2 timed out waiting to mount

...Apple$ diskutil mountDisk readOnly /dev/disk2
One or more volume(s) failed to mount
...Apple$ diskutil mount readOnly /dev/disk2s2
Volume on disk2s2 timed out waiting to mount

...Apple$ diskutil mount  /dev/disk2s3
Volume what_toDo on /dev/disk2s3 mounted
...Apple$ diskutil mount  /dev/disk2s4
Volume things_kept on /dev/disk2s4 mounted

Operation times out if I try to unmount the mounted partitions (\dev\disk2s3 and \dev\disk2s4). unmountDisk gives the error Unmount of disk2 failed: at least one volume could not be unmounted. An attempt to eject the disk also fails.

Next I checked whether fsck is running:

Apple$  ps aux | grep fsck 
root              1058  59.7 12.6 34676988 1053428   ??  R     2:59PM  18:01.42 /System/Library/Filesystems/hfs.fs/Contents/Resources/./fsck_hfs -y /dev/disk2s2 
Apple             1165   0.0  0.0 34122828    836 s000  S+    3:36PM   0:00.00 grep fsck

Everything remains unchanged even after killing fsck with sudo pkill -f fsck. First Aid in Disk Utility also does not work.

All this could have been avoided if I had plugged the charger on time. But now that the harm has been done, can you please suggest any solution? I hope this is solvable. The problematic partition \dev\disk2s2 contains my time machine backup of three years. Thank you for any help.

1 Answer 1


I could solve the primary problem by following the suggestion of https://apple.stackexchange.com/a/329482 . I downloaded and ran the free version of Disk Drill. It wanted to rebuild HFS+ catalog and ran some kind of scan. I did not rebuild the catalog but after this scan the time machine partition, /dev/disk2s2, mounted and I could mount or unmount all the partitions and eject the disk. I ran First Aid from Disk Utility and also diskutil repairVolume on all the partitions. I find that in both cases the process is taking a lot of time, especially I think at the steps checking catalog files' ,checking multi-linked files' and checking multi-linked directories. At the end though they give File system check exit code is 0'. This partition has become very slow otherwise also.

Apart from this, on this external hdd I am having to run `diskutil repairVolume' with sudo as otherwise I am getting the error :

Error starting file system repair for disk2s2 (time_mach2): This operation is restricted by Sandbox; check your settings in System Preferences > Security & Privacy > Privacy > Files and Folders (-69464).

I fail to understand and/or resolve this. There must be some problem with the partition /dev/disk2s2 or may be the entire disk still now though it has become accessible and usable. Any suggestion would be helpful. Thank you!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .