0

I have been downloading a (legit) torrent file to my external drive, and left it overnight, then I woke up and found unable to connect to my mac anymore on its own, and I have been trying every solution I could find on the internet and it wasn't fixed

SSD: Samsung Evo 970 inside Sabrent Enclosure (so it is external)

Computer: Macbook Pro 2018 with T2

I will show you the results of sudo gpt -r show /dev/disk2 below

gpt show: /dev/disk2: Suspicious MBR at sector 0
gpt show: /dev/disk2: Malformed MBR at sector 0
gpt show: /dev/disk2: Malformed MBR at sector 0
gpt show: /dev/disk2: Malformed MBR at sector 0
       start        size  index  contents
           0           1         MBR
           1  1953525167    

and the result of diskutil list

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *1.0 TB     disk2
   1:                       0xEE ⁨⁩                        1.0 TB     disk2s1

I have no idea what to do to fix this, please advise.

PS: I don't care about the data on it, just want the NEWLY PURCHASED drive to work again.

PS2: I also have a windows machine at my disposal, if that helps in anyway.

4
  • See apple.stackexchange.com/questions/55956/… for recovery software suggestions. For future reference, unless you absolutely must have it for cross-platform drives, don't use MBR [FDisk] or any format that does not have journaling, e.g. FAT, ExFAT etc. Journaled drives, [HFS+, APFS, even NTFS] are much more resilient to write/disconnect errors.
    – Tetsujin
    Jun 27 at 11:59
  • Hello Sir, I am not aiming to get back the data, I want the drive to work again, and what’s puzzling me is that I was using ExFat and I have no idea how I ended up here.
    – The BLSK
    Jun 27 at 12:15
  • Manufacturers supply drives in MBR/ExFAT because they work [for a given definition of work] straight out of the box. The first thing you should do with any new drive is reformat it GUID/APFS for SSD [or HFS+ for HD]. If Disk Utility can see it, reformat properly in there - hit Cmd/2 so you can see Devices, not just Volumes, & format the entire device.
    – Tetsujin
    Jun 27 at 12:20
  • I tried that, it gets stuck on waiting for partitions to activate🥲
    – The BLSK
    Jun 27 at 12:24

1 Answer 1

1

I was able to solve this problem, and I will tell you how below.

I first connected the drive to Ubuntu (Linux system)

Then I ran sudo sgdisk -Z /dev/sda

IMPORTANT: MAKE SURE it is /dev/sda, the above command will destroy everything

After that, you unplug then plug the external again.

Then I did sudo gparted to open the Gparted with root privileges.

Then it gives you an option in the Device tab to create a new partition table, I used GPT (it may tell you a backup one is broken and it will use another, just click ok)

Then now I created a new partition, used NTFS (I think others that are not grayed out would work too) (same kind of error might appear like last step)

Then ta-da, you unplug and replug and it works again.

Note: I had extensions like paragon on Mac and another one for Linux installed so that the system can read NTFS, Don't worry if the drive doesn't appear right away, you can log back to the macOS system and reformat the volume to exFAT or whatever you want.

I hope this helps someone!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .