2

I have a new MacBook Pro and whenever I'm using my external wireless mouse, the pointer is extremely laggy. Anecdotally, this only appears to happen when the external display is also in use; when using just the laptop display, the pointer moves fluidly. (The trackpad is not affected, with or without the external display.)

This answer suggests RF interference. I'm using an Apple Magic Keyboard -- which I believe is Bluetooth in the 2.4GHz range -- and 5GHz WiFi, but no other radio devices. Also, this doesn't explain why the problem only seems to occur when running on two displays.

Hardware:

  • MacBook Pro 2021 16", Monterey
  • Iiyama G-Master 32" (over HDMI)
  • Microsoft Sculpt Ergonomic mouse (with USB-C to USB-A dongle)
1
  • As this only happens with the external display, it might be related to the discrete GPU. This previous question deals with something similar, perhaps those solutions can help you as well? Commented Jun 21, 2022 at 21:55

2 Answers 2

1

The solution to this turned out to be quite random; discovered by accident. It’s probably related to the discrete GPU comment, above…

The external display started losing its signal intermittently. Trying it from another device worked fine, so the display wasn’t faulty. Thus it’s either the HDMI cable or the MBP. Trying a different HDMI cable was easy and, lo and behold, the display is working again…and so is the mouse!

Best guess is that the faulty cable was causing the dGPU to repeatedly power cycle in sync’ with whenever it could make a clear connection to the external display, but before the cable degraded to the point where it couldn’t maintain a sustained signal. The effect of which was manifested as laggy pointer movement.

1
  • This answer saved me hours, if not days. Thank you very much! :) Changed the faulty cable, problem solved.
    – Ugur
    Commented Jan 18, 2023 at 15:32
0

@xophmeister's answer is the correct answer. But if you're unable to change the cord and you need a temporary fix try this:

Go into Settings > Displays > Display Settings.... Select your display and change its refresh rate to a random option. Then once it has been updated, change it back to the refresh rate you usually use. This should effectively resync the connection. I'm not sure how long this fix lasts, it seems to be random.

Screenshot of the Refresh Rates in Display Settings

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .