0

(EDIT: I ran Apple Diagnostics and no problems were found.)

For some reason, suddenly Infinifactory causes my laptop to log out on my first attempt to launch it through Steam. Once I log back in, launch Steam, and try to play the game again, it runs perfectly. I found this question describing something similar. So, I checked in /Library/Logs and found that the last two times it logged me out, files like this were created: "WindowServer_2022-06-21-012452_thom-blair-iiis-computer-2.crash". Here is the content of that file. I don't see anything obvious in there, but I know next to nothing about crash logs.

In terms of troubleshooting:

  • Steam is fully up-to-date, as is the game
  • I verified the game files and no problems were found
  • I deleted the game and reinstalled it, then rebooted, same behavior
  • No other Steam games or programs cause this logging out
  • I have 1 guest account and 3 personal accounts (including mine) on my laptop
  • I ran Apple Diagnostics and no problems were found

Here are my computer specs:

  • MacBook Pro (Retina, 15-inch, Mid 2014)
  • 137.2 GB free HD space
  • 16 GB of RAM
  • OSX 10.13.6

2 Answers 2

1

This is just speculation, based on anecdotal experience
The crash log points to it being a graphics crash - MTLTexture & MTLDevice are part of the Metal graphics structure.

You're playing an old game & you're on an old OS, so I'm going to guess it's reliant on Open GL [I can only guess that Metal is perhaps having to translate this, I'm not really sure how that all works]. One thing about Open GL is it doesn't play nice with anything it has to share memory with. One common symptom of this is it logs out the current user, though it doesn't seem to hard crash the Mac.

Make sure you're not running anything else that uses the GPU in the same way - Photoshop & other things Adobe especially. Web browsers using video perhaps not, but it wouldn't hurt to quit any browsers first.

7
  • Well, I tried quitting my browser and all other minor apps, and now for some reason it won't launch the game at all...I tried 5 times in a row! I have no idea what this means. Any ideas? Jun 21, 2022 at 10:13
  • I even just ran Apple Diagnostics again and no issues were found. I'm stumped. I didn't have any apps open at all except Steam (which has to be open), but Steam does have graphics and little animations/ads running on it. This problem did start to happen once Steam did a sizable update to itself, so maybe Steam itself could be the culprit? But then, why would it have worked yesterday? I don't know. Jun 21, 2022 at 10:27
  • Are you rebooting between tests? There's a possibility Steam is no longer testing for compatibility right back to High Sierra, which has been totally unsupported for nearly three years. That Mac can be upgraded all the way to Big Sur [but no further].
    – Tetsujin
    Jun 21, 2022 at 10:35
  • I was not rebooting between all of my tests. Sometimes I was running Apple Diagnostics and I'm not sure if that counts as a reboot or cold boot. Is rebooting/restarting as good as cold booting/turning it off and then on again? As for Big Sur, I'm downloading it right now. Maybe it will help. Thank you. Jun 21, 2022 at 11:15
  • 1
    Adding your own answer is fine; I see you already did, you can just undelete it;) Accepting your own answer is also encouraged, if that's what actually fixed the issue. Ponting back to what helped you discover it is fine too. [Aside from that, I don't need the points, & with your answer we have the entire discovery process plus final solution. Win/win. ]
    – Tetsujin
    Jun 22, 2022 at 8:53
1

I upgraded to Big Sur (as mentioned by Tetsujin) and now the game consistently runs perfectly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .