6

I have an old USB connected SSD that I have been using as a Time Machine target on a Mac running macOS 12 (Monterey). This old drive was setup on this Mac under Monterey so it was formatted APFS from the get-go.

Recently I purchased a new SSD which will also be connected via USB. I would like to copy the entire contents of the old SSD to the new SSD and then start to use the new SSD as a Time Machine target. The old SSD would then be repurposed. Is this possible?

3 Answers 3

2

It’s possible, but usually not practical.

Open Disk Utility and restore from the old drive to the new drive. This makes a block by block copy of the data so that hard linked files are copied once. Monterey uses APFS by default, so it will be interesting if any of the snapshots copy.

I don't recommend this at all and would encourage you to set up the new drive as a second destination and then put the old drive on the shelf or just erase it when the new destination has enough history to be safe to discard. However, there's no harm in doing this if you are certain you don't erase / restore the empty drive to the one that's full by reversing the selection.

To perform a bulk copy - open Disk Utility:

  1. Select the drive that's new on the left sidebar
  2. Select Restore at the top of the main window
  3. Select the Backup drive on the left sidebar

Disk Utility Restore

The restore is TO the first selected volume FROM the one you select second.

4
  • 1
    I had already tried this and it does not seem to work for Time Machine APFS formatted drives.
    – Rumboogy
    Jun 17, 2022 at 0:48
  • If I get a test system I’ll try and give it a go on a smaller drive… @Rumboogy
    – bmike
    Jun 17, 2022 at 14:35
  • I just tried this method again and it failed again. In my system I currently have 2 SSDs as TM targets. So I tried restoring from both of them (in case it was an issue with just one of the old SSDs) to the new SSD with no success. Below is the error message that I got: Restoring “JMicron Tech Media” from “Crucial_ CT960M500SSD1 Media” Validating target... Validating source... Source volume format on device "/dev/disk4" is not valid for restoring Could not validate source - Operation not permitted The operation couldn’t be completed. (OSStatus error 1.) Operation failed…
    – Rumboogy
    Jun 17, 2022 at 19:19
  • @bmike I have referred to this answer in my answer to apple.stackexchange.com/questions/463617/…. Do you have any further thoughts on the possibility of copying APFS TM volumes?
    – Gilby
    Aug 27, 2023 at 23:53
0

I think I had success with Roadkil's Raw Copy launched from Hiren's Boot USB I did this on an old windows laptop. Messed it up by cloning the wrong drive though... Both were in APFS so it was impossible to know which one is which (because they were not recognised). The new drive had one backup and it was cloned successfully. (when connected to the old drive it was recognised as the new one and had one backup which I could browse)

If someone does this in the future I would recommend formatting the new drive to NTFS or FAT, so you can clearly see which drive is which!

1
  • What do you mean by "I think I ad success" ? Did you get the snapshots from one disk to another ? Can you develop on what was the initial condition (disk size and partition format) and the end result (disk format and retrieved files) ?
    – LotoLo
    Oct 12, 2023 at 22:59
0

I am following @Trajektorijus 's idea to use Windows and finally successfully migrate my Mac OS backup disk to another one.

The tool I am using is EaseUS Todo Backup. The free version does not have the feature to do disk-to-disk copy, but it can backup the disk as an image. I am backing up my original 1TB Mac OS backup to my NAS, which is big enough. My disk has some bad sectors and takes ~24 hours to fully backup as image. Then, I can use the restore feature to restore the image file to a new disk. I use "same as original partition" when doing restore.

After that, if mounting the new disk in Mac OS. It is found the APFS partition is broken, marked with a wrong type. Inspired by this post (you don't need to read it), I can change the partition type by doing this:

sudo gpt -r show disk2

Output:

       start        size  index  contents
           0           1         PMBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34           6         
          40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
      409640        2008         
      411648  1953113480      2  GPT part - 7C3457EF-0000-11AA-AA11-00306543ECAC
  1953525128           7         
  1953525135          32         Sec GPT table
  1953525167           1         Sec GPT header

Note down the start and size of index=2 partition. Run:

sudo gpt remove -i 2 /dev/disk2
sudo gpt add -i 2 -b 411648 -s 1953113480 -t apfs /dev/disk2

We are recreating the partition at the same position, but mark with -t apfs. Now, we should be able to see the Mac OS backups.

My new and old disks have both 1TB so I don't need to resize my container, but you should be able to find solutions online to expand a APFS container in your new disk.

Besides, as you can see there is a 2008 empty spaces between my index=1 and index=2 partitions. However, I don't think there is an easy way to claim them back.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .