1

I am running three Macs with macOS 10.13.6. All are in the same LAN, all are set up to connect to iCloud with the same account.

On one Mac, iCloud works fully (with all services).

On the other two, I am able to sign in to iCloud, but none of the synching services (Safari bookmarks, iCloud Drive, Notes etc.) work. They used to work fine in April (6 weeks ago).

Looking at errors in Console.app, I find these probably related messages:

fault   13:49:45.008478 +0300   apsd    Failed entitlement check 'com.apple.private.secure-apsclient' for <private>
fault   13:49:45.009632 +0300   apsd    Failed entitlement check 'com.apple.private.aps-connection-initiate' for <private>

error   13:49:45.359596 +0300   identityservicesd   ENGroupID initWithDataRepresentation - wrong data size -- Failed {data: (null)}

error   13:49:47.298499 +0300   cloudpaird  cloudpaird: sendResponderPairingMessage: Device info needed from CloudKit

error   13:49:47.459322 +0300   identityservicesd   ENGroupID initWithDataRepresentation - wrong data size -- Failed {data: (null)}
fault   13:49:48.809973 +0300   identityservicesd   Dropping message! {guid: <private>, processError: (null), decryptionError <private>

error   13:49:50.853389 +0300   cloudd  TIC SSL Trust Error [113:0x7fce1c461350]: 3:0
error   13:49:50.853854 +0300   cloudd  Task <BD314808-6292-4966-8170-6963A206C3DC>.<7> HTTP load failed (error code: -1202 [3:-9807])
error   13:49:50.853975 +0300   cloudd  Task <BD314808-6292-4966-8170-6963A206C3DC>.<7> finished with error - code: -1202
error   13:49:50.856458 +0300   cloudd  NetworkingError, NSURLErrorDomain/-1202/NSUnderlyingError, kCFErrorDomainCFNetwork/-1202 CFStreamUnderlyingError _kCFStreamErrorDomainSSL/-9807

On the Mac where it's working, I see instead:

default 14:06:19.167843 +0200   cloudd  TIC Enabling TLS [1476:0x7fc86511ae50]
default 14:06:19.168069 +0200   cloudd  TIC TCP Conn Start [1476:0x7fc86511ae50]

Apparently, there is a general SSL authentication issue causing the troubles. But I cannot find out what's causing the SSL issue. Googling only finds a few indidents where developers run into the "TIC SSL Trust Error", but there it's suggested that their own SSL setup is wrong, over which they have control. But in my case it's Apple's server and client, so I am not directly involved in the chain of this connection.

I've tried a few things blindly such as:

  • Log out of iCloud, reboot, log in again.
  • Log in to a different account, as suggested in this answer.
  • Disable the Mac's Firewall (and Little Snitch, too).
  • Perform all system updates (such as latest Safari and Security updates).
  • Re-install macOS 10.13.6 over the current installation (via Recovery), as I wondered if some system file's code signatures or entitlements got lost.
  • Look at the Keychains, first deleting all expired Certificates, then even delete all manually trusted Certs (i.e. such that were previous untrusted and I manually changed that).
  • Log out of iCloud, log in to another Mac user account and log in to iCloud there (so that my normal user's Keychains can't be the culprit).

Nothing made a difference. The "TIC SSL Trust Error" keeps appearing in the log.

As I can log in to iCloud, SSL generally works. I can also access web sites with https without problems, including icloud.com.

iMessage (Messages.app) works fine, too.

I wonder if there's a way to get more information about which part of the SSL cert trust chain is the issue here.

Also, is there a way to reset the entire Certificate system, perhaps, so that I can start with the bare minimum?

3 Answers 3

2

While the situation isn’t identical, I ran into a similar issue that started happening with my two Macs running macOS 10.13.6 around the same time April.

My iPhone was syncing to iCloud, but nothing else. Messages worked on the High Sierra Macs, but wasn’t syncing conversations from iCloud or between machines. Likewise, syncing of Notes and iCloud Drive content on the two Macs was not happening.

What tipped me off in Console.app were messages indicating that iCloud related connections to gateway.apple.com were failing due to an invalid certificate.

The certificate for this server is invalid. You might be connecting to a server that is pretending to be “gateway.icloud.com” which could put your confidential information at risk.

Like you, I looked for expired certs in the Keychains on my primary Mac and discovered that AppleISTCA2G1.cer was indeed expired. I replaced it with a fresh certificate from Apple PKI and immediately iCloud sync started working again on that machine.

Oddly, that same expired certificate wasn’t even on the second Mac, but adding it to the Keychain fixed the syncing issues on that machine as well.

2
  • 1
    I can confirm that adding that Cert to the MB Air, which still showed the cloudd issues in the Console log, fixed this. Thanks a lot for making the effort to sign up here and provide this answer which is a big relief to me, Grant! Commented Jun 16, 2022 at 15:02
  • 1
    You’re very welcome. I had been searching for a while to see if anyone else had documented this problem and was about to write a blog post about it. (I should probably still do that, right?) I saw your tweet and thought “Hey, that sounds familiar …” Commented Jun 16, 2022 at 16:00
1

You could try to use a proxy-server like Charles Proxy or similar (Wireshark may do, too) to find out which hosts are tried to be reached (hosts are not hidden by TLS, only the Path). Then you can try to find out if any of these hosts have invalid certificates.

If TLS doesn't work on multiple old systems out of a sudden, i'd say some certificate expired.

1
  • While I have managed to get one Mac fixed, I'll try your suggestion with the other. I, too, believe that it's an issue with an outdated certificate. I wish there were tools to easily browse and compare the certs in the keychain, but it's a rather tedious process, as far as I've experienced. Commented Jun 15, 2022 at 23:17
0

I managed to get the Mac working again by erasing the entire volume, then fresh-install High Sierra from the Recovery system (boot with cmd-R held down), and then restore all my data from a Time Machine backup I had made just before I started taking any of the steps listed in the question above. (BTW: After the initial install the desktop was unusable because the fonts were damaged somehow, to the point that I could not read any text. A reboot fixed that, though.)

Now iCloud works again.

That still doesn't explain what went wrong, but at least I have a working iCloud again.

I still have the other Mac showing the issue, because I had not done a fresh install on it, yet. I might instead try to compare the certificates in the keychains to see if I find the culprit there, but it's a low priority right now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .