1

FYI: Apple veteran (first Mac 1989), would call myself a Pro (unfortunately not at board level).

I have a 13" MBPR Early 2015 (A1502) here on which the internal trackpad fully works, but doesn't provide tactile feedback. The machine had a bloating battery (which I've removed; new battery waiting to be installed, once following trackpad problem is resolved). If I recall correctly the tactile engine/haptic feedback worked when I received the machine, but either stopped due to the further bloating battery or in the process of updating the macOS (which also has updated the board’s EFI). No water damage, machine is otherwise in perfect condition.

When opening System Preferences > Trackpad, it tells me that it doesn't find the trackpad and shows me a bluetooth connected Magic Trackpad, to which it would like to connect (perhaps as alternative as it thinks it's missing the internal trackpad, however there never was such a Magic Trackpad paired with that MBPR). ***)

Re missing trackpad: According to System Profiler > SPI the trackpad is there.

I've tried literally everything:

  • SMC Reset (countless times)
  • NVRAM Reset (countless times)
  • installation of two identical, known to be good Trackpad Flex Cables 821-00184-A
  • installation of two identical, known to be good Trackpad assemblies 810-00149-A
  • Safe Mode boot
  • re-installation of macOS Monterey
  • booting in Recovery Mode, erasing the SSD Volume group, restarting and installing Big Sur from bootable macOS Installer USB drive
  • swapping the SSD (!) with a different macOS version
  • deleting various related .plist files

Apple Diagnostics (formerly known as AHT Apple Hardware Test; "D" at boot) reports no damage/error. I know ... bloated battery might lead to broken flex cable, but I've replaced that already twice and even tried replacing the trackpad as such, as you can read above).


Bottom line

I'm at my wits’ end. The only thing I could imagine is either a hiccup in the board’s EFI or that the tension on the trackpad’s flex cable due to the bloated battery has lifted the FPC connector on the board (though nothing’s visible under a magnifier). Or it’s an active on-board component which is in charge of the tactile engine and passed away.

Ideas?

enter image description here enter image description here enter image description here

***) Update 1: Trackpad now shown again in System Settings > Trackpad ... still no haptic feedback

It’s absolutely crazy: I've learned here that the Trackpad preferences don't show up properly (and instead present the image of the Apple’s Magic (Bluetooth) Trackpad, as seen in the now striked screenshot above), if the battery is not present. Would be good if some board level expert could explain the reason why with a comment below.

So the Trackpad Prefs Pane is fully functional again, yet the Tactile Engine still provides no feedback. Changed the Trackpad settings back and forth, rebooted, SMC & NVRAM reset, basically tried the whole sh*t again ... still: Trackpad fully functional except for haptic feedback.

Update 2: Issue resolved ... but had to take a strange path

My friend and partner in crime asked an interesting question this morning: How does the Trackpad behave under Windows or Linux? (Being an Intel machine it can boot either natively).

So I created a bootable USB drive using Etcher and Ubuntu 22.04 LTS amd64. Booted from it, wiped the SSD using Ubuntu’s Disk Utility and installed Ubuntu on the SSD. Rebooted from the SSD. Still: Trackpad working but no haptic feedback. Left the machine alone for about an hour but saw when I left, that Ubuntu had began downloading updates, drivers etc. When I returned ... hallelujah! Tactile Engine was suddenly back. (I can't say whether the Ubuntu had rebooted meanwhile, as the system was set to Auto-Login).

So haptile feedback is back. The odyssey however continued for brief moment: Booted in Recovery Mode (CMD-R), which came up via Internet with an ancient El Capitan (10.11) Installer. The problem: Apple’s Disk Utility did not show the internal drive. Externals yes, but no internals.

Created a bootable USB drive with a Big Sur Installer, using Install Disk Creator, booted from it and surprisingly Disk Utility in that version/package showed the internal drive and allowed me to format it APFS. From there on everything went smoothly. Machine fully working again and running on macOS Monterey.

This Horror Story did cost me almost two full days...

P.S.: In the end, there was no hardware damage at all, although expected otherwise. All mentioned flex cables and all trackpad assemblies tested again and all units work.

5
  • I think you're right that it's likely to be a on-board component failure. Bloated batteries can cause all kinds of damage. You seem to have exhausted all other possibilities.
    – benwiggy
    Jun 14, 2022 at 9:51
  • Well, your and my assumption proved to be wrong. See updates above.
    – Dr. Woo
    Jun 14, 2022 at 17:16
  • Chapeau for your perseverance! So the Battery restored the prefs, but the reason for the return of haptic remains unknown?
    – benwiggy
    Jun 14, 2022 at 17:27
  • Should be a question with an answer.
    – Solar Mike
    Jun 14, 2022 at 18:08
  • @benwiggy Correct. Re-installing a battery re-enabled the Trackpad prefs (can also be achieved without battery, as described here: tonymacx86.com/threads/…), but that wasn't the problem. IMO the problem lied in the EFI/board’s firmware, and the Ubuntu Installation magically fixed or overwrote the part of it. I can tell you that I was close to throwing the MacBook against the wall (or sell it as defect/as is), which I just couldn't as the machine is in almost mint condition despite being 7 years old.
    – Dr. Woo
    Jun 14, 2022 at 20:53

1 Answer 1

1

Problem solved as described in Section „Update 2“ of question above (for details see above, here’s the recap):

  1. Created bootable USB drive with Ubuntu 22.04 LTS amd64 using Etcher.
  2. Booted from that (alt-Key pressed after Restart).
  3. Formated SSD using Disk Tool in Ubuntu.
  4. Installed Ubuntu on SSD and rebooted from SSD.
  5. Let Ubuntu install its proposed drivers and updates.
  6. Restarted Ubuntu.
  7. Haptic feedback should be back by now.
  8. As Internet Recovery (CMD-R immediately after Restart) comes up with an old macOS El Capitan (10.11) environment and the included Disk Utility version doesn't find the internal drive/SSD: Using another Mac downloaded Big Sur or Monterey from Apple’s App Store and created a bootable USB drive with that macOS Installer using Install Disk Creator.
  9. Booted from that USB drive (alt-Key pressed after Restart).
  10. Opened Disk Utility and formatted now found internal SSD to APFS.
  11. Installed macOS on internal SSD.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .