2

Lately my Mac cannot connect to any scanners. I get this error message every time I open the system scan tool on any of the connected scanners:

Failed to open a connection to the device (-21345)

I've tried removing all scanners and re-installing.

I've tried doing "reset print system" on each connected device and then rebooting my system.

I've tried buying a brand new scanner (HP Deskjet 2755e in this case) but that new scanner has the same issue.

Tried updating to Mac OS 11.6 Big Sur.

This is the 2nd Mac I've had that is affected by this and so far the only thing that has ever (temporarily) fixed it is wiping the entire thing and reinstalling my system. I shouldn't have to do this every time I get this error.

All the scanners are connected over Bonjour AirPrint.

How do I fix this?

3
  • Having this problem with a Brother all-in-one on macOS Monterey. It was fine when I first got the new iMac a few months back, then Image Capture would pick it up if I ended and restarted the app; today it wouldn't pick it up until I power-cycled the scanner itself. I don't think it's a connectivity issue; printing to the device works without any issues whatsoever.
    – Alger
    Commented Jun 23, 2022 at 15:05
  • I had similar issues with a Canon scanner. Finally I disabled the firewall on the Mac which made scanning possible. Interestingly enough it kept working even after I reenabled the firewall again. Computers, they are just magic.
    – nohillside
    Commented Jul 16, 2022 at 14:39
  • I just encountered this same problem - inspired by @nohillside's observation I tried disabling the Perimeter81 VPN that I have to use for work (not just disconnect but also quit the app) and after re-opening Image Capture I was able to scan again. It's weird that it interferes with scanning but not printing.
    – Anentropic
    Commented Sep 28, 2022 at 15:21

3 Answers 3

0

This may be a matter that Apple keeps requiring more and more permissions. For now, at least, I have fixed this for my Brother all-in-one on Monterey by enabling full disk access.

I added Brother iPrint&Scan application to Settings → Privacy & Security -> Full Disk Access. It also required a hard reset of the printer (that is, pull out the power cord at both ends for 10 seconds).

It did not require a Mac reboot for me but if it starts failing again I may try that. After I got scan working again, I disabled Full Disk Access and scanning stopped working, so this may be the fix.

0

A customer of mine had this error message, too. I solved it by ensuring the default wifi band is 2.4 GHz only by giving the 5 GHz band a different name.

Many peripheral devices that network via wifi use only 2.4 GHz. If your computer is flip-flopping between 2.4 & 5 GHz via 'band steering' configured at the modem-router, then you may experience that the connection to the 2.4 GHz peripheral works intermittently.

'Band steering' (as one modem-router manufacture calls it) allows a single SSID name to be applied to both bands, and the computer then automatically connects to whichever band, presumably depending on which band offers the best connection.

I think Apple computers for decades have been able flip-flop between differing networks with the same SSID – even with differing bands but, possibly for the benefit of Windows boxes, using a single name for differing SSIDs was discouraged.

I had the same trouble with an old Sonos music player. I upgraded the wifi one day to include 5 Ghz with the same name as the 2.4 GHz and it intermittently stopped connecting till I gave the 5 GHz band a differing name. I suspect a new Sonos player can now handle 5 GHz band.

0

I had this issue a while back with a Brother AIO printer. It would occasionally spin up but not print, and the scanner often gave the error above.

Brother support gave me two suggestions. The first was to force everything on my network to 2.4 GHz, which was less than popular. The other was to upgrade the device's firmware to the current version.

The second suggestion actually worked. The new firmware navigated whatever weirdness was going on with the Wi-Fi and everything has worked fine since then.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .