13

I just did a complete reinstall of my late 2012 Mac Mini, with the latest OS it supports: Catalina (10.15.7). I'm trying to enable remote login via SSH, but when I check the box in System Preferences → Sharing, it keeps saying "Remote Login starting..." and I can't connect to it via SSH.

It looks like the same problem mentioned here. How can I fix this?

1 Answer 1

20

The problem can be solved by manually adding the relevant launch daemon yourself via the Terminal, with the following command:

sudo launchctl load -w /System/Library/LaunchDaemons/ssh.plist
3
  • Thanks, that works like a charm. I'll just add that in order to disable the ssh daemon once again, it is necessary to execute the command sudo launchctl **unload** -w /System/Library/LaunchDaemons/ssh.plist
    – alb-i986
    Commented Jul 24, 2022 at 21:53
  • Awesome. As soon as I ran the command in the terminal, the message "Remote Login starting..." changed to "Remote Login: On" with a green dot instead of yellow. Commented Sep 3, 2023 at 22:46
  • Is this solution supposed to also re-enable the functioning of the GUI (i.e. the Remote Login checkbox)? Or do we use it in place of the GUI? I have this problem - the launchctl commands do switch the GUI as @Tyler Collier describes, but I still can't get ssh login to work.
    – Chap
    Commented Feb 3 at 23:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .