5

This issue is possibly related to this one, though I'm not quite sure how to translate those steps.

I'm using macOS 12.4 on a MacBook Pro (14-inch, 2021), and would like to use iTerm2 as a replacement for Terminal. At present, every time I try to access something in a protected directory (e.g. Downloads, network volumes), I'm asked for permission, like this:

“iTerm2” would like to access files on a network volume. (Don't Allow/OK)

When I allow this access for Terminal even once, I'm never asked again and it just works. I've also tried giving iTerm2 “Full Disk Access” in Security & Privacy, and still get this. I think this is a bug of some kind, given the different behavior for Terminal. Does anyone know how to give iTerm2 (and other third party apps) this access?

3
  • Is this from the MacPorts port? I tried reinstalling it from the installer on the website and the problem is tentatively better. Full Disk Access still doesn't prevent the first popup but now, once I click "OK" to let it access each of the protected folders individually, iTerm seems to remember without having the permissions dialog popup again and again. Jul 24, 2022 at 19:03
  • 1
    Yes, I installed with MacPorts. I wonder whether that somehow is affecting how these permissions work? If applications installed from MacPorts can't have permissions set properly, that would be very annoying. And agreed, it makes things unusable!
    – Mike Lynch
    Jul 27, 2022 at 3:34
  • Interesting. May be an issue with MacPorts then. Jul 27, 2022 at 17:39

2 Answers 2

3

Enable Full Disk Access in Security & Privacy:

Security & Privacy

https://gitlab.com/gnachman/iterm2/-/wikis/fulldiskaccess

3

Emre's answer is correct for iTerm2 in general, but for whatever reason this solution doesn't seem to work with the MacPorts package for iTerm2. This is a known issue, see bug report: https://gitlab.com/gnachman/iterm2/-/issues/10519#note_1060501202

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .